Make WordPress Core

Opened 10 months ago

Closed 10 months ago

Last modified 8 months ago

#58531 closed defect (bug) (fixed)

Twenty Seventeen: Post Template block has list-style: disc in editor when front end has no list style

Reported by: nkeller15's profile nkeller15 Owned by: audrasjb's profile audrasjb
Milestone: 6.3 Priority: normal
Severity: minor Version: 6.2.2
Component: Bundled Theme Keywords: has-patch commit
Focuses: css Cc:

Description

Steps to reproduce:

  1. Activate Twenty Seventeen Theme
  2. Add the Posts List block and choose the Grid pattern
  3. Notice how disc list style is applyied to list elements
  4. Save and view published page where discs are not visible

Attachments (6)

SCR-20230613-ltzu.png (51.3 KB) - added by nkeller15 10 months ago.
editor screenshot
SCR-20230613-ltzu.2.png (51.3 KB) - added by nkeller15 10 months ago.
front end screenshot
58531.patch (586 bytes) - added by nkeller15 10 months ago.
patch
2017-post-template-front.png (41.2 KB) - added by sabernhardt 10 months ago.
front end page, with no discs for list items
2017-post-template-editor-before.png (90.7 KB) - added by sabernhardt 10 months ago.
editor, before applying patch
2017-post-template-editor-with-patch.png (90.1 KB) - added by sabernhardt 10 months ago.
editor, with the patch

Download all attachments as: .zip

Change History (10)

@nkeller15
10 months ago

editor screenshot

@nkeller15
10 months ago

front end screenshot

@nkeller15
10 months ago

patch

@sabernhardt
10 months ago

front end page, with no discs for list items

@sabernhardt
10 months ago

editor, before applying patch

@sabernhardt
10 months ago

editor, with the patch

#1 @sabernhardt
10 months ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to 6.3
  • Summary changed from Twenty Seventeen - List style disc in post template when front end has no list style to Twenty Seventeen: Post Template block has list-style: disc in editor when front end has no list style

The discs also show in the editor the List view, and the patch removes them from both the Grid and List views (as it is on the front).

Using the :not(.wp-block-gallery, .wp-block-post-template) selector list does not increase the specificity. Because this only changes the editor, I am not concerned about browsers that cannot support a selector list inside :not().

#2 @audrasjb
10 months ago

  • Owner set to audrasjb
  • Status changed from new to reviewing

Self assigning for final review and commit.

#3 @audrasjb
10 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 55913:

Twenty Seventeen: Improve Grid View variation rendering in the editor for the Post List block.

This changeset updates Twenty Seventeen's block editor stylesheet to remove an unwanted disc list style on the "Grid" variation of the Post List block.

Props nkeller15, sabernhardt.
Fixes #58531.

This ticket was mentioned in Slack in #core-test by ironprogrammer. View the logs.


8 months ago

Note: See TracTickets for help on using tickets.