Make WordPress Core

#58591 closed defect (bug) (duplicate)

E2E tests: Investigate inconsistent navigation timeouts

Reported by: joemcgill's profile joemcgill Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: Cc:

Description

Recently, our automated end-to-end (E2E) tests have been failing inconsistently due to a Navigation Timeout error:

TimeoutError: Navigation timeout of 30000 ms exceeded

You can see an example of this type of error in a recent run of the workflow against on a PR to update the About Page, which should not have any affect on E2E tests.

The full list of runs where you can see this happening inconsistently, but frequently, is here: https://github.com/WordPress/wordpress-develop/actions/workflows/end-to-end-tests.yml

Often rerunning these failing jobs fixes the issue, but we should investigate why this is happening and try to reduce the frequency if possible since it leads to a poor experience and unnecessary overhead to rerun these failing jobs.

Change History (1)

#1 @mukesh27
11 months ago

  • Milestone 6.3 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #58592.

Note: See TracTickets for help on using tickets.