Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#58768 closed defect (bug) (reported-upstream)

Safari: Pasting into post title is broken

Reported by: lukasbesch's profile lukasbesch Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.2.2
Component: Editor Keywords:
Focuses: ui, accessibility, javascript, administration Cc:

Description

Steps to reproduce:

  1. Go to the block editor to edit a post using Safari.
  2. Click on the post title (the cursor position does not matter). Assume the current post title has the value old.
  3. Paste text using your keyboard (cmd + v). Assume the pasted value is NEW.
  4. The title is now oldNEWold. The cursor position is now at the beginning (before the first letter).

I only tested on a mac using cmd + v.
This only happens in Safari. My Version is 16.5 (17615.2.9.11.6, 17615).
This also happens on a fresh bare bone WordPress 6.2.2 site, with no plugins and the default theme.
It also happens if you first select all the text in the post title (expecting to overwrite it)
It does NOT happen if you paste using the mouse and context menu.

Change History (1)

#1 @swissspidy
8 months ago

  • Component changed from General to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Looks like this is a known issue in Gutenberg. Closing in favor of https://github.com/WordPress/gutenberg/issues/51047

Note: See TracTickets for help on using tickets.