Make WordPress Core

Opened 12 months ago

Last modified 11 months ago

#58927 reopened defect (bug)

Set featured image missing

Reported by: ernasx's profile ernasx Owned by:
Milestone: Awaiting Review Priority: normal
Severity: major Version: 6.2.2
Component: General Keywords: needs-screenshots close
Focuses: administration Cc:

Description

Latest version 6.2.2, php version 8.1
Why it happens - unknown
Happens even if all plugins deactivated, changed theme
Expected set featured image button, this section is missing
Theme support added to the functions.php, but this happens with all twenty themes as well
Server information below

Set featured image is missing, cannot set featured image. Tried all browsers, disabling all plugins, changing theme. Only installing "disable gutenberg" plugin helps and "set featured image" back again.

Fresh install.
Also this happens with other older websites (v6.1.1)

On some websites it works fine, but there is slight delay before it appears.

cPanel Version 110.0 (build 7)
Apache Version 2.4.57
MySQL Version 10.3.38-MariaDB-log-cll-lve
Architecture x86_64
Operating System linux
Path to Sendmail /usr/sbin/sendmail
Path to Perl /usr/bin/perl
Perl Version 5.16.3
Kernel Version 3.10.0-962.3.2.lve1.5.80.el7.x86_64

Change History (6)

#1 follow-up: @prashantbhivsane
12 months ago

  • Keywords needs-screenshots added
  • Resolution set to invalid
  • Status changed from new to closed

Hello @ernasx,

Thank you for opening this ticket.

You are talking about Featured Image when adding a new Page, please correct me if I am wrong.

I tried to replicate the issue with WP 6.2.2 and PHP 8.1 Fresh Install, but I was able to see as well as Set the Featured Image when creating a new Page or Post.

Are you seeing any issues on your console (perhaps issues related to JS)?

Also, could you share the screenshot here?

#2 @prashantbhivsane
12 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#3 follow-up: @audrasjb
12 months ago

  • Keywords close added; needs-patch removed

Hello, welcome to WordPress Trac and thank you for opening this ticket,

This sounds more like a support question, and not a bug report against WordPress Core, since it is not reproductible on a fresh WordPress install.

Would you mind reporting your issue in WordPress support forums?
https://wordpress.org/support/forum/how-to-and-troubleshooting/

#4 in reply to: ↑ 1 @ernasx
12 months ago

Replying to prashantbhivsane:

Hello @ernasx,

Thank you for opening this ticket.

You are talking about Featured Image when adding a new Page, please correct me if I am wrong.

I tried to replicate the issue with WP 6.2.2 and PHP 8.1 Fresh Install, but I was able to see as well as Set the Featured Image when creating a new Page or Post.

Are you seeing any issues on your console (perhaps issues related to JS)?

Also, could you share the screenshot here?

That is a funny part with this issue. Maybe it is server related, cause it happens randomly - on one hosting it works fine, if you transfer the same website with duplicator to another hosting it is gone.
There is no set featured image on the fresh install as well.

There are some errors in the console related to json posted below

Failed to load resource: the server responded with a status of 508 ()
/wp-json/wp/v2/media/606?context=edit&_locale=user:1 Failed to load resource: the server responded with a status of 508 ()
/wp-json/wp/v2/blocks?context=edit&per_page=100&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/block-patterns/patterns?_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/themes?context=edit&status=active&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/600?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/417?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/595?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/598?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/599?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/419?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/settings?_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/taxonomies?context=edit&per_page=100&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/608?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/416?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/597?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/607?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/418?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/604?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/596?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/603?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/593?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/602?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/601?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/592?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/594?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/420?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/media/421?context=edit&_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET
/wp-json/wp/v2/block-patterns/categories?_locale=user:1 Failed to load resource: net::ERR_CONNECTION_RESET


#5 in reply to: ↑ 3 @ernasx
12 months ago

Replying to audrasjb:

Hello, welcome to WordPress Trac and thank you for opening this ticket,

This sounds more like a support question, and not a bug report against WordPress Core, since it is not reproductible on a fresh WordPress install.

Would you mind reporting your issue in WordPress support forums?
https://wordpress.org/support/forum/how-to-and-troubleshooting/



Trust me - tried everything before posting here.

#6 @doubleforte
11 months ago

FWIW, I had the same problem.

WP is only part of my site, and I have consolidated css outside of the WP theme dir. Therefore there is no style.css file. Turns out, if you are missing the style.css file and you look at the theme's settings (not even changing anything, just _looking at them_!) it will blow away access to the featured image even though the theme files still contain add_theme_support('post-thumbnails', ['post']);. Strangely, the public-facing pages still respected the featured image.

TL;DR: Make sure you have a style.css file in your theme dir. Even if the file is empty, it just needs to exist.

Note: See TracTickets for help on using tickets.