Make WordPress Core

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#59049 closed defect (bug) (duplicate)

post__in array(0) workaround no longer works in 6.3

Reported by: youdaman's profile Youdaman Owned by:
Milestone: Priority: normal
Severity: major Version: 6.3
Component: Query Keywords:
Focuses: privacy Cc:

Description

Opening a new issue as per comment and subsequent instruction here https://core.trac.wordpress.org/ticket/28099#comment:32

The previous hack of passing array(0) to post__in to return no posts no longer works, and instead displays all posts.

This has consequences for any developers using this method for content privacy/segregation.

Change History (3)

#1 @Youdaman
11 months ago

  • Resolution set to invalid
  • Status changed from new to closed
Last edited 11 months ago by Youdaman (previous) (diff)

#2 @swissspidy
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to duplicate

Duplicate of #28099.

#3 @SergeyBiryukov
11 months ago

  • Component changed from General to Query
Note: See TracTickets for help on using tickets.