WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#5921 closed defect (bug) (fixed)

fatal error trying write new post

Reported by: matheuseduardo Owned by: ryan
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: has-patch
Focuses: Cc:

Description

after last "svn update blog", to revision 6914, I can't open page "post-new.php", I receiving error:

Fatal error: Call to undefined function wp_get_current_user() in /(...)/blog/wp-includes/user.php on line 87

Attachments (1)

script-loader.patch (1.0 KB) - added by azaozz 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 lloydbudd6 years ago

  • Milestone 2.3.4 deleted
  • Resolution set to invalid
  • Status changed from new to closed

You didn't include what branch you are on.

2.3/wp-includes/pluggable.php includes that function.

Closing as invalid for now. (PS. Please don't update the milestone, leave that to a core member of the team.)

comment:2 techcookies6 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

well, i'm having the same problem: branch is trunk, revision is 6937. The problem seems to be a collision with some plugins. I had Simple Tags version 1.3 activated and had the same problem. I first commented the plugin-inclusion code (wp-settings, 334-342), then i deactivated the plugin and reincluded the lines and it works.. Now i don't know at which point the plugin collides with the system but this seems a viable work-around.

comment:3 DD326 years ago

Sounds like an incompatible plugin that causes the problem then?

Re-close as invalid if thats the case, as its a plugin issue rather than a WordPress issue i believe.

comment:4 matheuseduardo6 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

when I disable all plugins "post-new.php" worked!..

it's really some plugin incompatible! I'll try to find it.

thx for all

comment:5 ryan6 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

We saw this before and it was due to a change in how scripts were queued. Let's investigate to see if that is the cause again. See #5605 #5612

comment:6 ryan6 years ago

wp_default_editor is being used in the script loader again. That's the problem.

comment:7 follow-up: ryan6 years ago

[6587] needs to be resurrected.

comment:8 ryan6 years ago

  • Owner changed from anonymous to ryan
  • Status changed from reopened to new

comment:9 in reply to: ↑ 7 azaozz6 years ago

  • Keywords has-patch added

Replying to ryan:

[6587] needs to be resurrected.

Sry, my bad... Attaching the patch to put it back.

azaozz6 years ago

comment:10 ryan6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6971]) Restore JIT script localization. Props azaozz. fixes #5921

Note: See TracTickets for help on using tickets.