Make WordPress Core

Opened 10 months ago

Closed 6 months ago

#59438 closed defect (bug) (duplicate)

Posts Page Redirects to Home Page

Reported by: mymothersdaughter's profile mymothersdaughter Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.3.1
Component: General Keywords:
Focuses: ui, administration Cc:

Description

When using Settings > Reading > A Static Page configured as: Homepage (Home) and Posts page: (Blog), when you click the Preview button in the Blog page Editor, the Preview redirects to the Homepage and the preview shown is the homepage content and not the Blog page content.

If the Settings is changed to "Your latest posts", the Blog page content will display.

This happens with any page assigned to Homepage. The Blog page will be redirected to whatever content is on the Homepage.

I've downgraded as far back as WordPress 6.0 running PHP 7.4, switched themes, deactivated plugins and tried this same scenario on two different hosting platforms with the same results.

I found an old bug report from 16 years ago that seems very similar to this - https://core.trac.wordpress.org/ticket/4773.

Would like to know if this is indeed a bug.

Change History (2)

#1 @GaryJ
10 months ago

  • Focuses ui administration added

I can replicate this. While editing the Blog page, and selecting "Preview in new tab", the link URL points to https://{my domain}/blog/?preview_id=110&preview_nonce=...&preview=true - note the presence of /blog/ in there.

The tab that opens though ends up as https://{my domain}/?preview_id=110&preview_nonce=... - a visible redirect has happened and the /blog/ is gone from the URL.

If I manually add the /blog/ part back, then I do get the contents of the blog page, albeit with no amendments from the editing since the Blog page is handled via the "Blog Home" Template on the Twenty Twenty-Three theme.

Even if it may not make sense to preview a static blog page which is being handled by a block theme template, the UI is a little confusing to new (and experienced) users.

#2 @poena
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #49969.

Hi @mymothersdaughter @GaryJ I believe this is a duplicate of https://core.trac.wordpress.org/ticket/49969. If not, please comment and I will re-open the ticket.

Note: See TracTickets for help on using tickets.