Make WordPress Core

Opened 7 months ago

Closed 7 months ago

#59471 closed defect (bug) (fixed)

List Style is shown in blog list section

Reported by: yosephtamang's profile yosephtamang Owned by:
Milestone: 6.4 Priority: normal
Severity: critical Version: 6.4
Component: General Keywords:
Focuses: Cc:

Description

I installed WordPress 6.4 Beta 1 and found that list style appears after each blog at blog section.
WordPress 6.4 Beta 1
PHP 8.1
Theme TT4
Local server Laragon
Browser : Chrome

Attachments (4)

beta4 list style.png (9.4 MB) - added by yosephtamang 7 months ago.
reproduce-attempt-test-report.png (774.1 KB) - added by hellofromTonya 7 months ago.
Test Report: Could not reproduce the issue
Screenshot 2023-10-05 at 5.30.42 PM.png (1.7 MB) - added by deepakvijayan 7 months ago.
Screenshot 2023-10-05 at 5.29.37 PM.png (1.5 MB) - added by deepakvijayan 7 months ago.

Change History (16)

#1 @aslamdoctor
7 months ago

Just tested this on fresh local setup and doesn't seem to happen on it. Can you provide more details like if you have made any changes on home page, or what kind of content these test posts have which might be causing this issue.

screenshot:
https://prnt.sc/yq10Uy_nyGsO

@hellofromTonya
7 months ago

Test Report: Could not reproduce the issue

#2 @hellofromTonya
7 months ago

Reproduction Report

This report validates that the issue can be reproduced.

Environment

  • OS: macOS
  • Localhost Server: Nginx
  • PHP: 8.1
  • WordPress: 6.4-beta1-56730-src
  • Browser: Chrome and Firefox
  • Theme: Twenty Twenty-Four (TT4)
  • Active Plugins: None

Steps to Reproduce

  1. Add 3 posts with:
    1. the following content (switch to Code Editor to paste):
      <!-- wp:paragraph -->
      <p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. In eu consectetur magna, semper posuere orci. Phasellus lacinia molestie nisl vel rutrum. Pellentesque tempus nec magna vel tristique. Donec a tellus nulla. Aenean eget augue sed tellus rhoncus scelerisque vitae porta mi. Aliquam dignissim viverra magna eget tincidunt. Nam tristique blandit sapien sollicitudin sagittis. Integer condimentum ipsum tortor, vel sollicitudin nisl sodales at. Duis hendrerit, risus eget venenatis aliquam, nisl diam vestibulum odio, id porta lectus leo tempus diam. Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Maecenas eleifend viverra nisl, non varius lectus rutrum convallis. Etiam in tortor nibh. Pellentesque pulvinar mauris metus, id congue nisl hendrerit a.</p>
      <!-- /wp:paragraph -->
      
      <!-- wp:paragraph -->
      <p>Vestibulum arcu urna, luctus at tincidunt sed, tincidunt ut metus. Morbi quis viverra enim. Aenean cursus lorem et mi tristique, vel malesuada libero fringilla. Aenean vitae rhoncus dolor. Etiam turpis neque, lobortis id libero nec, feugiat dignissim eros. Nulla viverra feugiat dui, sed pulvinar tortor sagittis ut. Fusce quis ex blandit, dignissim urna eu, luctus turpis. Aliquam erat volutpat. Vestibulum feugiat velit id gravida pulvinar. Vestibulum dictum placerat varius. Vestibulum efficitur erat lorem, nec consectetur dui luctus a. Quisque vulputate turpis nec sem condimentum placerat. Quisque in urna justo. Nulla orci sapien, efficitur in augue ac, gravida maximus nulla. Quisque dignissim enim eu libero fringilla, sed aliquet massa pulvinar.</p>
      <!-- /wp:paragraph -->
      
    2. Set any image to be the post's "Feature image".
    3. Publish each post.
  2. Go to the site's frontend and refresh.
  3. Scroll down to the "Watch, Read, Listen" section to view the posts rendering.

Actual Results

  • ❌ I was unable to reproduce the reported issue. It rendered correctly for me.

See reproduce-attempt-test-report.png.

#3 @hellofromTonya
7 months ago

  • Keywords reporter-feedback needs-testing-info added
  • Milestone changed from Awaiting Review to 6.4

Hello @yosephtamang,

Welcome back to WordPress Core's Trac :) Thank you for reporting the issue you're having.

I was unable to reproduce it (see my Test Report above). Is the content you're using different?

Could you share step-by-step instructions on how to reproduce the issue? For example:

  • I shared the content from the post's "Code Editor" and that I set the image as the featured image.
  • Are there any plugins activated?

This kind of information is helpful as it gives contributors a way to step through to reproduce and then investigate why it's happening.

Thank you :)

Trac: Moved the ticket into 6.4 for visibility. For now, leaving the Component as General until more information is given to determine which component might be where the problem lies.

#4 @kafleg
7 months ago

I did nothing just installed 6.4 Beta 1 and I see this,
https://i.rankmath.com/i/CYC9If

Means I see *(dot).

  • Fresh Install of Beta 1
  • Laragon local server
  • PHP 8.1
  • Edge browser
  • Windows 11
  • Active plugins: none

#5 @yosephtamang
7 months ago

Welcome to everybody.

I have Windows 11. I looked at the Chrome browser as well as Brave but the bug is still present. I did not made any changes in home page and no any plugin activated at all. I created three posts with some content and added featured image on all three posts. I published them all.

I returned back to dashboard and clicked on visit site. In blog section, there are dots after the featured image.

#6 @deepakvijayan
7 months ago

Checked this on 6.4-beta2. But was not able to reproduce the issue.

Tried testing on Chrome as well as Firefox.

Attached are screenshots for reference.

#7 @oglekler
7 months ago

I think this is related to #59489 and perhaps because a fix was made there the bug is no longer reproduced here.

#8 @nicolefurlan
7 months ago

It would be great to get one or two more test reports to verify that this issue is no longer reproducible.

@kafleg and @yosephtamang – since you both were previously able to reproduce this bug, would you be able to retest to see if it is now resolved, and submit a test report with your findings?

#9 @ashikur698
7 months ago

Working just fine.

OS: Mac
Browser: Chrome
WordPress: 6.4 Beta 3
PHP: 8.1.23
Web Server: nginx

Screenshot: https://prnt.sc/BW7twFx5I87i
Screenshot: https://prnt.sc/twayukGJEf2H

#10 @kafleg
7 months ago

This issue is now fixed in WordPress 6.4 Beta 3.

#11 @nicolefurlan
7 months ago

Wonderful! Thank you everyone. It seems that this issue has been resolved elsewhere as it's no longer reproducible. I think we can close this. (cc @hellofromTonya)

#12 @hellofromTonya
7 months ago

  • Keywords reporter-feedback needs-testing-info removed
  • Resolution set to fixed
  • Status changed from new to closed

Well that's great news of the issue being resolved :)

It is likely that r59489 also resolved this reported Windows issues. Let's mark it as fixed by r59489.

Note: See TracTickets for help on using tickets.