Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#60494 closed defect (bug) (fixed)

The loading icon does not show correctly when installing the plugin

Reported by: huzaifaalmesbah's profile huzaifaalmesbah Owned by: swissspidy's profile swissspidy
Milestone: 6.5 Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: has-screenshots has-testing-info has-patch
Focuses: Cc:

Description

The loading icon does not show correctly when installing the plugin

Steps to Reproduce

  1. Go to Add New Plugin
  2. Select any plugin then click mouse right button and click "Open link in new Tab"
  3. Click Install Now button and see.

https://i.ibb.co/xfMQzcR/Screenshot-2024-02-11-at-9-53-49-AM.png

Attachments (1)

60494.diff (601 bytes) - added by swissspidy 3 months ago.

Download all attachments as: .zip

Change History (6)

#1 @devmuhib
3 months ago

  • Keywords needs-patch has-screenshots has-testing-info added

#2 @huzaifaalmesbah
3 months ago

  • Version set to trunk

#3 @zunaid321
3 months ago

Reproduction Report

Description

This report validates whether the issue can be reproduced.

Environment

  • WordPress: 6.5-beta1
  • PHP: 7.4.33
  • Server: LiteSpeed
  • Database: mysqli (Server: 10.5.19-MariaDB-cll-lve / Client: mysqlnd 7.4.33)
  • Browser: Chrome 121.0.0.0
  • OS: Windows 10/11
  • Theme: Twenty Twenty-Four 1.0
  • MU Plugins: None activated
  • Plugins:
    • Custom Post Type UI 1.15.1
    • Hostinger 1.9.9
    • LiteSpeed Cache 5.5.1
    • Test Reports 1.1.0
    • WordPress Beta Tester 3.5.2

Actual Results

Followed the instructions of @huzaifaalmesbah

🐞 Bug occurs where the loading/installing icon is displaced.

Supplemental Artifacts

https://i.ibb.co/Zhhymcb/image-1.png

Last edited 3 months ago by zunaid321 (previous) (diff)

#4 @swissspidy
3 months ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Awaiting Review to 6.5
  • Owner set to swissspidy
  • Status changed from new to assigned
  • Version trunk deleted

Just FWIW, these links are not meant to be opened in a new tab, but with a normal click that opens a modal/dialog for installing the plugin.

The issues occurs because the media query is of course different for modal vs non-modal.

@swissspidy
3 months ago

#5 @swissspidy
3 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 57697:

Upgrade/Install: Improve plugin install button appearance.

Fixes a misaligned spinner icon when opening the plugin details information in a new tab rather than the modal, and then installing the plugin in that window.

Props huzaifaalmesbah, zunaid321, swissspidy.
Fixes #60494.

Note: See TracTickets for help on using tickets.