Make WordPress Core

Opened 5 weeks ago

Closed 5 weeks ago

#61033 closed defect (bug) (duplicate)

WordPress 6.5 update breaks activate plugin redirect action

Reported by: terraling's profile terraling Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5
Component: Plugins Keywords:
Focuses: Cc:

Description

Prior to WordPress 6.5 on the Add New Plugins page you can install and activate a plugin via ajax actions on the corresponding button for the plugin.

When you click "Activate" the page redirects to the main plugins page and a banner is shown saying plugin activated, as per this screenshot:

https://i2.paste.pics/07bc9bc75acac3b81766fc7c609b0d08.png

After updating to WordPress 6.5 (or 6.5.2) the redirect no longer happens. Clicking the Activate button activates the plugin, and the button changes to "Active" and becomes inert, and nothing happens.

https://i2.paste.pics/e372a5971144829a853164dd4faf3af2.png

This appears to be a bug rather than an intended UI change.

Change History (2)

#1 @luminuu
5 weeks ago

I think this is similar to this ticket, where a discussion is already happening: https://core.trac.wordpress.org/ticket/60992

#2 @davidbaumwald
5 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @terraling. This is indeed a duplicate of #60992. If you have any thoughts on the updates being made there, feel free to comment on that ticket.

Note: See TracTickets for help on using tickets.