Make WordPress Core

Opened 5 weeks ago

Closed 4 weeks ago

#61036 closed defect (bug) (duplicate)

Twenty Twenty: Pullquote block custom border does not have default solid style in editor

Reported by: viralsampat's profile viralsampat Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5
Component: Bundled Theme Keywords: dev-feedback has-patch
Focuses: ui, css Cc:

Description

Hello,

I have reviewed the "Pullquote" block and found that it's font family is not same in editor & front-end sides. Also, the border is not appearing in editor side.

Here, I have provided issue:

Issue: https://share.cleanshot.com/2GW9BkVKwmqdlCLZtL4N

Environment info:


  • WordPress version: WordPress 6.5.2 running,
  • Twenty Twenty Version: 2.6
  • Browser: Google Chrome, Version 123.0.6312.124 (Official Build) (arm64)
  • Device: MacBook Air M1
  • OS: macOS 14.4.1 (23E224)
  • Gutenberg plugin: Version 18.1.2

Thanks,

Attachments (4)

61036.patch (1.3 KB) - added by viralsampat 5 weeks ago.
I have checked above mentioned issue and resolved it. Here, I have added my patch.
CleanShot 2024-04-19 at 02.53.13@2x.png (331.5 KB) - added by viralsampat 5 weeks ago.
Back-end
CleanShot 2024-04-19 at 02.52.55@2x.png (261.4 KB) - added by viralsampat 5 weeks ago.
Front-end
61036.1.patch (1.1 KB) - added by sabernhardt 5 weeks ago.
replaces border: none with border: 0 solid

Download all attachments as: .zip

Change History (7)

@viralsampat
5 weeks ago

I have checked above mentioned issue and resolved it. Here, I have added my patch.

@sabernhardt
5 weeks ago

replaces border: none with border: 0 solid

#1 @sabernhardt
5 weeks ago

  • Keywords has-patch added
  • Summary changed from Twenty Twenty Theme: The pullquote block font family and border not properly appear in editor side. to Twenty Twenty: Pullquote block custom border does not have default solid style in editor

The font-family changed in the editor with WordPress 5.6, but the front end is still correct. That is already reported as the main part of #53158.

To experience the issue with the border:

  1. Activate Twenty Twenty.
  2. Go to the post editor.
  3. Add a Pullquote block, and insert text for the quote and citation.
  4. Find the Border settings in the sidebar, and add a width value. You could also use a custom border color, but do not set the border style (solid, dotted, dashed) there.
  5. Save and view/preview on the front end.

The block will have a border on the front without showing one in the editor.

61036.1.patch sets the border style to solid, with zero width by default, so it can show in the editor when someone adds a border width.

#2 @sabernhardt
5 weeks ago

The border issue was already reported on #57338, which was closed in favor of a larger project in #55974.

#3 @sabernhardt
4 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #57338.

Note: See TracTickets for help on using tickets.