WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#7552 closed defect (bug) (fixed)

Bring crazyhorse to stable

Reported by: ryan Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Merge select bits of crazyhorse to trunk.

Attachments (25)

crazy_manage.diff (47.1 KB) - added by ryan 10 years ago.
Merge changes to management pages
crazy_merge.diff (172.4 KB) - added by ryan 10 years ago.
edit-settings.diff (5.5 KB) - added by ryan 10 years ago.
Edit Settings panel, sans CSS
removeh2.patch (22.9 KB) - added by Viper007Bond 10 years ago.
Remove most <h2>'s, theme-editor.php still needs attention
show-threaded-reply-via-js.diff (1.6 KB) - added by Viper007Bond 10 years ago.
Dunno if best solution or not, but here's my try (onload sucks)
show-threaded-reply-via-js.2.diff (1.9 KB) - added by Viper007Bond 10 years ago.
Use jQuery and all of it's awesomeness
show-threaded-reply-via-jquery.diff (1.9 KB) - added by Viper007Bond 10 years ago.
Reupload, HTML preview wasn't working
extra-tag-cat-columns.diff (2.5 KB) - added by Viper007Bond 10 years ago.
Add slug to tags, add slug/parent to cats + escape names
tag-cat-slug-columns.diff (1.8 KB) - added by Viper007Bond 10 years ago.
Just add slug columns, parent column is unnecessary
comment_type-filter.patch (4.2 KB) - added by Viper007Bond 10 years ago.
Add comment_type filtering to Edit Comments page
search-boxes-nocss.patch (5.2 KB) - added by Viper007Bond 10 years ago.
Restore search boxes, leave CSS to whoever will be reorganizing the filters, etc.
consolidate-search-query-code.patch (5.1 KB) - added by Viper007Bond 10 years ago.
Consolidate code in search boxes via new function (updated for r9073)
7552.dashboard-1.diff (63.0 KB) - added by mdawaffe 10 years ago.
switch to meta_box API (mostly backward compatible), draggable dashboard, recent comments dashboard widget improvement
remove-pagenow.diff (4.9 KB) - added by Viper007Bond 10 years ago.
Remove $pagenow from the search form actions
7552.dashboard-2.diff (3.0 KB) - added by mdawaffe 10 years ago.
CSS, validation
7552.dashboard-3.diff (1012 bytes) - added by mdawaffe 10 years ago.
edit link on hover for matt and jane
7552.datetime_presets.patch (6.1 KB) - added by Viper007Bond 10 years ago.
Add presets to Settings for picking date/time formats
7552.datetime_presets.2.patch (6.1 KB) - added by Viper007Bond 10 years ago.
Add presets to Settings for picking date/time formats
7552.datetime_presets.3.patch (6.1 KB) - added by Viper007Bond 10 years ago.
Add presets to Settings for picking date/time formats (JS fixes for IE)
post_states.diff (2.5 KB) - added by ryan 10 years ago.
datetime-selector-bugfix.patch (952 bytes) - added by Viper007Bond 10 years ago.
If custom field left blank, leave blank rather than "\c\u\s\t\o\m"
delete-spam-time-check.patch (1.3 KB) - added by Viper007Bond 10 years ago.
Don't delete spams created after page load but before "Delete All" button press
delete-spam-time-check.2.patch (1.3 KB) - added by Viper007Bond 10 years ago.
Previous patch may have been problematic, stick with Akismet's exact method as it's known to work
7552.dashboard-4.diff (12.8 KB) - added by mdawaffe 10 years ago.
add media button for quickpress, js and css tweaks
7552.dashboard-4.2.diff (12.5 KB) - added by mdawaffe 10 years ago.
insert media button for quickpress, js and css tweaks

Download all attachments as: .zip

Change History (99)

@ryan
10 years ago

Merge changes to management pages

#1 @ryan
10 years ago

(In [8682]) Merge crazyhorse management pages. see #7552

@ryan
10 years ago

#2 @ryan
10 years ago

(In [8691]) Collapse crazyhorse to trunk. Incoming! see #7552

#3 @ryan
10 years ago

(In [8692]) New row style for Content->Pages. see #7552

#4 @ryan
10 years ago

(In [8693]) Check if not empty rather than isset. fixes #7553 see #7552

#5 @ryan
10 years ago

(In [8694]) Add comment author column heading. see #7552

#6 @santosj
10 years ago

I thought only bits and pieces would be applied to to the main trunk.

#7 @santosj
10 years ago

Also, there are even more notices from the merge. Will need another patch to fix them all from the crazyhorse branch.

#8 follow-up: @ryan
10 years ago

We left out several things from the merge, but most stuff came over. The fixed bottom bar on the edit screens tested miserably so we dropped them and put the submit stuff in a meta box for now. That will change. Most of the dashboard changes were not merged. Some of that will come in later. There's still lots of place holder stuff floating around.

#9 @santosj
10 years ago

Is it a good time to start creating Codex documentation for the new screens or are they still going to be changing?

#10 in reply to: ↑ 8 @santosj
10 years ago

Replying to ryan:

We left out several things from the merge, but most stuff came over. The fixed bottom bar on the edit screens tested miserably so we dropped them and put the submit stuff in a meta box for now. That will change. Most of the dashboard changes were not merged. Some of that will come in later. There's still lots of place holder stuff floating around.

Excuse me, I spoke without thinking and remembering the screens I've seen. You've left out some parts that disturbed me about crazy horse, so I'm happy about that. I shown it to a co-worker and he doesn't like it. Then again, he didn't like WordPress 2.5, but now he does.

Dude! It is a lot more intuitive now. I'm not sure I'm going to be "svn up" until the final changes on my sites.

#11 @ryan
10 years ago

They will be changing. crazyhorse is basically an implementation of a wireframe. It hasn't really been "designed" yet. The detailers need to come in and make it look good.

Notable areas that still have some big changes coming are the media uploader, the dashboard, and the edit screens. Menu structure might be tweaked a bit too.

#12 @azaozz
10 years ago

(In [8697]) Some css cleanup and fixes after the merge, see #7552

#13 @Viper007Bond
10 years ago

The grey navigation bar at the top has issues. If you hover directly over the text, it does nothing. Only if you move the mouse below the text a bit does it actually hightlight.

#14 follow-up: @Otto42
10 years ago

Yikes! I just did an svn up and saw the new version.

Where are all the Settings pages? Like, all the plugins have their own settings pages which are now wholly inaccessible...

#15 @ryan
10 years ago

Settings will probably move up to the top-level.

#16 @ryan
10 years ago

(In [8705]) Move Setting menu to top-level. see #7552

#17 @ryan
10 years ago

(In [8707]) Move Install Plugins menu to the bottom. see #7552

#18 @ryan
10 years ago

(In [8708]) Menu back-compat fixes. see #7552

#19 @ryan
10 years ago

(In [8709]) Remove Stats from My Account menu. fixes #7567 see #7552

#20 @ryan
10 years ago

(In [8710]) Move manage_comments_nav action after Apply. see #7552

@ryan
10 years ago

Edit Settings panel, sans CSS

#21 @ryan
10 years ago

Patch implements the "Edit Settings" panel for the post edit page. There's no CSS for it yet, so it's ugly.

#22 @ryan
10 years ago

(In [8712]) First cut of 'Show on screen' metabox show/hide. Needs styling. see #7552

#23 in reply to: ↑ 14 @santosj
10 years ago

Replying to Otto42:

Yikes! I just did an svn up and saw the new version.

Where are all the Settings pages? Like, all the plugins have their own settings pages which are now wholly inaccessible...


I'm not going to svn up until the trunk is stable again. It appears that the new branding, "hemorrhage" for 2.7 isn't kidding. Trunk is highly experimental, it appears, at the moment and live blogs should not be updated unless they are willing to test the new system.

I will advise checking out an earlier revision before the crazyhorse merge went in.

#24 @azaozz
10 years ago

(In [8715]) Typecast to prevent errors when option is not set, see #7552

#25 follow-up: @santosj
10 years ago

Are you sure type casting is the correct fix? What is causing the error in the first place? Shouldn't it be looked at to see if the code needs to be changed to return the fix for correcting the error?

#26 in reply to: ↑ 25 @azaozz
10 years ago

Replying to santosj:

Are you sure type casting is the correct fix? What is causing the error in the first place? Shouldn't it be looked at to see if the code needs to be changed to return the fix for correcting the error?

The output from

get_user_option( "meta-box-hidden_$page" )

is expected to be an array. If the option is not set it returns false. Can either typecast or use a conditional.

#27 @ryan
10 years ago

(In [8724]) Global pagenow. see #7552

#28 @azaozz
10 years ago

(In [8726]) Some 'Show on screen' metabox settings styling, see #7552

#29 @mrmist
10 years ago

In [8727] (and earlier) the page wp-admin/users.php#add-new-user does not display a submit (Add User) button in IE7, so it's impossible to add new users. The button displays as intended in FF3.

Also, as an aside, it wasn't obvious (to me) where to find "Users". It's actually in "Utilities" (rather than Settings or somehow accessible directly from an admin profile area). It took me a while to find.

#30 @ryan
10 years ago

(In [8729]) Move post row generation to functions in prep for some AJAX work. see #7552

#31 @ryan
10 years ago

(In [8734]) Menu fixes. see #7552

#32 @ryan
10 years ago

(In [8735]) Menu fixes. see #7552

#33 @ryan
10 years ago

(In [8750]) Fix delete page nonce. see #7552

#34 @ryan
10 years ago

(In [8751]) crazyhorse dash see #7552

#35 @ryan
10 years ago

(In [8752]) Show Settings for edit page form. see #7552

#36 @ryan
10 years ago

(In [8753]) Show Settings for edit link form. see #7552

#37 @ryan
10 years ago

(In [8756]) Add sub page padding back. see #7552

#38 @ryan
10 years ago

(In [8758]) Add edit and delete links to the Content->Links rows. Add get_edit_bookmark_link(). Add caching for individual bookmarks. see #7552

#39 @mrmist
10 years ago

Actually playing with it a bit more it looks like the settings "Save Changes" buttons do not appear in IE7 for

General Writing Discussion Permalinks Misc

And various other pages depending on (seemingly) how deep the pages are. Short pages display the buttons no problem.

#40 @ryan
10 years ago

(In [8859]) Remove privacy checkbox from submitbox. see #7552

#41 @ryan
10 years ago

(In [8862]) Privacy Options for pages. see #7552

#42 @ryan
10 years ago

(In [8863]) View links for posts and pages. see #7552

#43 @ryan
10 years ago

(In [8864]) Reorder comment actions. see #7552

#44 @ryan
10 years ago

(In [8868]) Don't allow submit box to be hidden. see #7552

#45 @ryan
10 years ago

(In [8870]) Themes menu rewording. see #7552

#46 @ryan
10 years ago

(In [8883]) Move Show Settings into header and rename Advanced Options. Move preview links into submit box. see #7552

#47 @ryan
10 years ago

(In [8893]) Rename some media text. see #7552

#48 @ryan
10 years ago

(In [8895]) Implement attachmenet delete link. Use get_edit_post_link(). see #7552

#49 @ryan
10 years ago

(In [8905]) Move media settings to options-media.php. see #7552

#50 @ryan
10 years ago

(In [8906]) Remove image options from misc options whitelist. see #7552

#51 @ryan
10 years ago

(In [8908]) Edit and Delete links for tags page. see #7552

#52 @ryan
10 years ago

(In [8910]) Edit and Delete links for categories. see #7552

#53 @ryan
10 years ago

(In [8911]) Edit and Delete links for link categories. see #7552

#54 @ryan
10 years ago

(In [8916]) Edit and Delete links for users. see #7552

@Viper007Bond
10 years ago

Remove most <h2>'s, theme-editor.php still needs attention

#55 @ryan
10 years ago

(In [9032]) h2 removal per wireframes. Props Viper007Bond. see #7552

@Viper007Bond
10 years ago

Dunno if best solution or not, but here's my try (onload sucks)

@Viper007Bond
10 years ago

Use jQuery and all of it's awesomeness

@Viper007Bond
10 years ago

Reupload, HTML preview wasn't working

#56 @Viper007Bond
10 years ago

Meh @ Trac.

#57 @Viper007Bond
10 years ago

Oh crap, wrong ticket anyway.

@Viper007Bond
10 years ago

Add slug to tags, add slug/parent to cats + escape names

@Viper007Bond
10 years ago

Just add slug columns, parent column is unnecessary

#58 @ryan
10 years ago

(In [9045]) Add slug columns. Props Viper007Bond. see #7552

@Viper007Bond
10 years ago

Add comment_type filtering to Edit Comments page

#59 @ryan
10 years ago

(In [9046]) Comment type filter from Viper007Bond. see #7552

@Viper007Bond
10 years ago

Restore search boxes, leave CSS to whoever will be reorganizing the filters, etc.

#60 @ryan
10 years ago

(In [9069]) Restore search boxes. CSS to-do. Props Viper007Bond. see #7552

@Viper007Bond
10 years ago

Consolidate code in search boxes via new function (updated for r9073)

#61 @ryan
10 years ago

(In [9074]) Function to prep 's' for display on admin pages that don't run WP_Query(). Props Viper007Bond. see #7552

@mdawaffe
10 years ago

switch to meta_box API (mostly backward compatible), draggable dashboard, recent comments dashboard widget improvement

#62 @mdawaffe
10 years ago

7552.dashboard-1.diff

  • Switches dashboard widgets to meta_box API. Adding dashboard widgets using the widget API is mostly backward compatible: notices and links won't work, everything else should.
  • Make dashboard widgets draggable (two columns).
  • Recent Comments widget improvements: inline reply, moderation, etc.

Needs:

  • Styling
  • Wireframe calls for more generic Feed widget - can adapt the current "secondary" (planet) widget.
  • Put back Right Now widget
  • Recent Drafts widget needs work.
  • QuickPress widget needs styling and Add Media button.

#63 @mdawaffe
10 years ago

svn add wp-admin/js/dashboard.js

#64 @ryan
10 years ago

(In [9103]) Draggable dash, first cut. Props mdawaffe. see #7552

#65 @azaozz
10 years ago

(In [9107]) Fix warnings in recent_comments on dashboard, see #7552

@Viper007Bond
10 years ago

Remove $pagenow from the search form actions

@mdawaffe
10 years ago

CSS, validation

#66 @mdawaffe
10 years ago

7552.dashboard-2.diff

Tweaks:

  • CSS
  • Validation

#67 @ryan
10 years ago

(In [9120]) Dashboard styling and validation fixes from mdawaffe. see #7552

@mdawaffe
10 years ago

edit link on hover for matt and jane

#68 @ryan
10 years ago

(In [9121]) Edit link on hover for dash. Props mdawaffe. see #7552

#69 @ryan
10 years ago

(In [9122]) Remove pagenow from search form actions. Props Viper007Bond. see #7552

@Viper007Bond
10 years ago

Add presets to Settings for picking date/time formats

@Viper007Bond
10 years ago

Add presets to Settings for picking date/time formats

@Viper007Bond
10 years ago

Add presets to Settings for picking date/time formats (JS fixes for IE)

#70 @Viper007Bond
10 years ago

Whoops, forgot to click the "replace" checkbox when I uploaded #2 (bug fix). Patch #3 fixes f'ing IE being retarded when it comes to change().

Anyway, there's a patch (use #3 or whatever's latest if I upload another) to add some presets to the date/time selectors at Settings -> General.

@ryan
10 years ago

#71 @ryan
10 years ago

(In [9131]) Date and time presets from Viper007Bond. see #7552

@Viper007Bond
10 years ago

If custom field left blank, leave blank rather than "\c\u\s\t\o\m"

@Viper007Bond
10 years ago

Don't delete spams created after page load but before "Delete All" button press

#72 @azaozz
10 years ago

(In [9183]) Don't delete spam created after page has loaded but before "Delete All" button pressed, props Viper007Bond, see #7552

@Viper007Bond
10 years ago

Previous patch may have been problematic, stick with Akismet's exact method as it's known to work

@mdawaffe
10 years ago

add media button for quickpress, js and css tweaks

@mdawaffe
10 years ago

insert media button for quickpress, js and css tweaks

#73 @ryan
10 years ago

(In [9219]) Dashboard updates from mdawaffe. see #7552

#74 @ryan
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.