Make WordPress Core

Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#8556 closed defect (bug) (worksforme)

"Last edited by" not correct username

Reported by: worldwidewaiting's profile WorldWideWaiting Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Revisions Keywords: reporter-feedback 2nd-opinion
Focuses: Cc:

Description

The "Last edited by" text on the edit-post page shows current username, not username who has last edit.

I've done this:

  • on a clean wordpress, latest svn
  • login as admin
  • make new post
  • make new user, type "editor"
  • login as the new user
  • go to edit-post page of the created post
  • it says "Last edited by [current username] on [date created] at [time created]"

Change History (16)

#1 @sivel
15 years ago

Seems to work fine for me in 2.7-RC2-10167

I see the username of the person who actually last edited the post.

#2 @vladimir_kolesnikov
15 years ago

I think it is not a bug, it is a feature: when you are editing a page/post, WordPress puts a lock on it (wp-admin/post.php). First it checks the lock and if the post is locked, it says something like "Warning: %username is currently editing this post". If the post is not locked, it puts a lock on it and lock is owned by the current user.

#3 @WorldWideWaiting
15 years ago

Strange feature; when a post (of user A) is locked; it says (when viewing with user B) the good "last edited by" with the good "publish date". When post is not locked, it says "last edited by [current user]", with the time of publish or real last edit.

Isn't it strange, or am I? ;-)

#4 @vladimir_kolesnikov
15 years ago

Well, maybe strange... The problem is that _edit_last post meta is used both to identify the lock owner and the name of the user who edited the post last time.

As far as I understand, if the User B does NOT actually edit the post and close it, the lock will be eventually removed (or expire) and you will see that the User A was the last editor.

#5 @DD32
15 years ago

  • Milestone changed from 2.7 to 2.7.1

#6 @miqrogroove
15 years ago

This bug affected 2.6 as well. It has been very confusing ever since the revision system was added.

#7 @ryan
15 years ago

  • Component changed from General to Revisions
  • Milestone changed from 2.7.1 to 2.8
  • Owner anonymous deleted

#8 @Denis-de-Bernardy
15 years ago

  • Keywords needs-patch reporter-feedback added

my understanding is there's an autosave status now. might that have fixed it?

if not, patch needs to make WP look into revisions only, rather than revisions and autosaves.

#9 @hakre
15 years ago

  • Keywords 2nd-opinion added; needs-patch removed

Just tested against 2.8 Trunk. Can't reproduce. Usernames are properly displayed in the line below the textarea.

Can someone else please try to reproduce as well with 2.8 svn?

#10 @Denis-de-Bernardy
15 years ago

  • Milestone 2.8 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

please re-open with a test case

#11 @rooodini
14 years ago

  • Cc rooodini added
  • Version changed from 2.7 to 2.9.2

Hi there - I'm new to trac..

This ticket says "re-open with a test case". Can I reopen it please? I have this bug with 2.9.2

#12 @miqrogroove
14 years ago

  • Version changed from 2.9.2 to 2.7

This was a duplicate of #10004, please make a new ticket for 2.9.

#13 @rooodini
14 years ago

  • Cc rooodini removed

#14 @rooodini
14 years ago

Ah ok no problem. Thanks!

#15 @rooodini
14 years ago

Actually, I'm not convinced this was a duplicate of #10004... I don't think the bug has anything to do with autosaves. But I'll make a new ticket for 2.9.2.

#16 @rooodini
14 years ago

New ticket: #12763

Note: See TracTickets for help on using tickets.