WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#16700 closed feature request (wontfix)

Add a button for embedding flash videos

Reported by: Slobajossi Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: General Keywords: needs-patch
Focuses: Cc:

Description

I hope this isn't intentionally omitted, but since upgrading to WP 3.1 there's no button for embedding flash videos any more in visual editor.

I see few threads in forum on this, but cannot see anyone reported this as a bug.

Change History (14)

comment:1 scribu3 years ago

Are you sure the button wasn't added by a plugin?

comment:2 Slobajossi3 years ago

  • Keywords reporter-feedback removed

Absolutely 100% sure. If you want to add a video from your server, i.e. not from YouTube, Vimeo, etc. this was the best way, especially for those who don't want to mess with the code and html editor.

You can see a screenshot other user posted in the forum - http://thisismyurl.com/wp-content/uploads/2011/02/WordPress-31-Update-Before-After.png

Also here is the longest thread in the forum about this http://wordpress.org/support/topic/31-what-happened-to-embedded-video-button

comment:3 scribu3 years ago

I am running a clean install of 3.0.5 and I don't see that button.

comment:4 scribu3 years ago

  • Keywords close added

comment:5 scribu3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

That button is present in WP 2.9, but was removed in WP 3.0, so it's intended behaviour.

comment:6 filosofo3 years ago

Are you referring to the swfuploader mentioned here? #14647

It was removed for license-incompatibility reasons in 3.1.

comment:7 Slobajossi3 years ago

OK, thank you filosofo, obviously it's the licensing thing.

comment:8 filosofo3 years ago

Actually I meant flv player and embedder. The swf uploader is still in WP.

comment:9 Slobajossi3 years ago

Yes, actually it's embedder.

And actually I do not understand where's the licencing problem, since it just helps people who don't understand code to embed the .swf file. It doesn't upload anything, just embed the video.

On TinyMCE website the button is present on their demo site and I see other applications using this without any problem.

comment:10 filosofo3 years ago

The problem is that to be distributed with WordPress, which is under the GPL license, the component must be GPL-compatible.

Unfortunately it has a license that does not have the same freedoms as the GPL. In particular, the author states of the license:

I get a few questions about what kind of license this player is released under. I don´t know, really.
You can do pretty much whatever the hell you want with it as far as I´m concerned ;) So use it for whatever, redistribute it, etc.
As long as you don´t try to profit from/sell it in any way, it´s probably fine. If you are unsure, just drop me a quick email.

A GPL-compatible license cannot restrict you from profiting from the code. It can't tell you to check with the author first to see if your intended use is allowed.

However, I bet WordPress's oEmbed will let you embed most of the same videos we comparable ease. If not, surely there is a plugin that will.

comment:11 Slobajossi3 years ago

I'll use the html editor and I personally will not have problems with embedding the code, but I asked this because of the users that only use the visual editor and especially new-comers to WP.

If you search the forum with "video 3.1" you'll notice few threads on this subject, and obviously oEmbed will do the job for the most folks. But still this creates an obstacle for those wishing to embed the internal swf or flv link from own server. There can be various reasons for using own server instead of YouTube or Vimeo, like one user stated, he needs it for training material.

Anyway, thank you both, scribu and filosofo, on your time.

comment:12 hakre3 years ago

  • Keywords needs-patch added; close removed
  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Summary changed from No button for embedding flash videos to Add a button for embedding flash videos
  • Type changed from defect (bug) to feature request

Probably it makes sense to switch this ticket from a bug-report to a feature request to "Add a button for embedding flash videos" as it was requested.

As it's only a licensing problem it should be technically possible to provide this functionality.

comment:13 ocean903 years ago

  • Milestone set to Awaiting Review

comment:14 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

Sounds like a good idea for a plugin.

When the licensing issue was raised, it was decided we should simply remove it, rather than replace it, because so few used it.

Note: See TracTickets for help on using tickets.