WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 20 months ago

#17100 closed defect (bug) (duplicate)

Featured image shouldn't be published until hitting the update button

Reported by: ocean90 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Post Thumbnails Keywords: ux-feedback
Focuses: Cc:

Description (last modified by scribu)

How to reproduce:

  • choose a post and go to the edit screen
  • set a featured image

Expected behavior:
The image isn't live until I hit the update button.

What's happened:
The image is published.


Because all other changes aren't published directly the post thumbnail shouldn't published too.

(IRC discussion)

Change History (7)

comment:1 ocean903 years ago

  • Keywords needs-refresh removed

comment:2 scribu3 years ago

  • Description modified (diff)

When you say "the image is published", you actually mean that the post thumbnail ID is updated.

comment:3 linuxologos3 years ago

If it's relevant, custom fields behave the same way. I would think editing the featured image is more like editing a custom field than dealing with yet another image/attachment of the post.

comment:4 scribu3 years ago

Actually, it is editing a custom field, only with a fancier interface. :)

comment:5 andrewryno3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12922

comment:6 scribu3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.