WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#18884 closed defect (bug) (fixed)

TwentyEleven nav#nav-single blocks clicks

Reported by: kingkool68 Owned by: azaozz
Milestone: 3.3 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch dev-feedback
Focuses: Cc:

Description

In image.php the following HTML is rendered:

<nav id="nav-single">
      <h3 class="assistive-text">Image navigation</h3>
      <span class="nav-previous">
      <a title="Title" href="http://example.com/something">← Previous</a></span>
      <span class="nav-next">
      <a title="Title" href="http://example.com/something">Next →</a></span>
</nav>

The links within the nav element are unclickable in Firefox 7.0.1 on OSX. In style.css on line 1701, You can remove the postion:relative; property and change top:-0.3em; to margin-top:-0.3em; to accomplish the same effect.

Attachments (1)

18884.patch (383 bytes) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (7)

SergeyBiryukov3 years ago

comment:1 SergeyBiryukov3 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.3

Confirmed in Windows browsers as well: Firefox 7, Chrome 14, Opera 11.51, Safari 5.0.3. My results are a bit different though:

  1. The unclickable links are in <div class="entry-meta">, not in <nav id="nav-single">.
  2. Happens in single.php too.

Replying to kingkool68:

In style.css on line 1701, You can remove the postion:relative; property and change top:-0.3em; to margin-top:-0.3em; to accomplish the same effect.

This makes it the other way round: links in <div class="entry-meta"> become clickable, and the ones in <nav id="nav-single"> become unclickable.

Removing width: 100%; seems to make the links in both blocks clickable.

comment:4 iandstewart2 years ago

Confirmed. Removing the 100% in 18884.patch works for me too.

comment:5 jane2 years ago

  • Keywords dev-feedback added

comment:6 azaozz2 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [19369]:

TwentyEleven: prevent #nav-single from blocking clicks, props SergeyBiryukov, fixes #18884

Note: See TracTickets for help on using tickets.