WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#22106 closed defect (bug) (duplicate)

SVN Notify emails don't support UTF-8

Reported by: pento Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: WordPress.org Site Keywords:
Focuses: Cc:

Description

If there are UTF-8 characters in the changelog, they are shown as UTF-8 numerical codes, instead of the appropriate character.

For example, see this change:

http://plugins.trac.wordpress.org/changeset/608203/automatic-updater

Compared to the attached email screenshot.

Attachments (1)

utf8-email-errors.png (52.4 KB) - added by pento 9 years ago.
Screenshot of notification email

Download all attachments as: .zip

Change History (4)

@pento
9 years ago

Screenshot of notification email

#1 @nacin
9 years ago

  • Milestone changed from Awaiting Review to WordPress.org
  • Summary changed from Plugin revision emails don't support UTF-8 to SVN Notify emails don't support UTF-8

Affects core and any other commit emails as well.

#2 @samuelsidler
8 years ago

  • Milestone WordPress.org deleted
  • Status changed from new to closed

Essentially a dupe of #meta23. There are a number of encoding issues with emails and we should audit and fix them all.

#3 @SergeyBiryukov
8 years ago

  • Keywords needs-patch removed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.