WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#22184 closed defect (bug) (fixed)

Regression: Sample permalink box appearing makes the page jump

Reported by: johnbillion Owned by: nacin
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.5
Component: UI Keywords: has-patch commit
Focuses: Cc:

Description

In 3.4 a space is left in the UI for the sample permalink box so it doesn't make the page jump down when it appears after the first autosave.

[21789] removed the height property on #edit-slug-box and reduced the bottom margin on #titlediv, causing this behaviour to regress.

Attachments (3)

22184.patch (429 bytes) - added by johnbillion 7 years ago.
22184.2.patch (346 bytes) - added by lessbloat 7 years ago.
22184.3.patch (444 bytes) - added by lessbloat 7 years ago.

Download all attachments as: .zip

Change History (11)

@johnbillion
7 years ago

#1 @johnbillion
7 years ago

  • Keywords has-patch added

Patch to restore previous behaviour.

#2 @nacin
7 years ago

  • Milestone changed from Awaiting Review to 3.5

I reported this at 80:ticket:21598. Fine with spinning it out to here.

@lessbloat
7 years ago

#3 @lessbloat
7 years ago

Could we just add height to the pages that show the permalink, and skip adding it to the "add new" page like in 22184.2.patch. This avoids having a big gap under the title box on the "add new" page:

http://f.cl.ly/items/19031y2v253S1W451W11/add-post-gap.jpg

#4 @johnbillion
7 years ago

That patch doesn't achieve anything. The point of adding the gap on the 'add new' page is so that everything on the page below the title field doesn't get bumped down when autosave kicks in and the sample permalink appears.

#5 @lessbloat
7 years ago

Ah... my bad, in testing stuff locally I never discovered that auto-save works without manually clicking the "save draft" button (for whatever reason it doesn't work for me locally). I just tried it on a live site, and you're right. ;-)

I thought we were just trying to avoid having the editor move down when they clicked to edit the permalink. Scratch 22184.2.patch.

Though I'm still not a fan of that big empty gap. :-)

@lessbloat
7 years ago

#6 @lessbloat
7 years ago

I tightened up the margin-bottom by 2px and added some line-height to #edit-slug-box (now, when you click the edit button, the permalink doesn't move) in 22184.3.patch.

#7 @helenyhou
7 years ago

  • Keywords commit added

22184.3.patch works for me.

#8 @nacin
7 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In [22279]:

Make some space for the Permalink preview to appear on post-new.php. props johnbillion, lessbloat. fixes #22184.

Note: See TracTickets for help on using tickets.