WordPress.org

Make WordPress Core

Opened 18 months ago

Closed 4 weeks ago

#22341 closed defect (bug) (fixed)

Future-dated top-level pages are not automatically added to custom menus

Reported by: jamocreations Owned by:
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.4.2
Component: Menus Keywords: needs-patch needs-unit-tests
Focuses: Cc:

Description

I've found that future-dated top-level pages are not automatically added to custom menus, despite my setting to do so.

When a future-dated page is published, the new menu item is added to the 'posts' table (a new row with 'post_type' = 'nav_menu_item'). However, the new menu item is not added to the 'wp_term_relationships' table. In short, the menu item is not saved correctly, and hence does not show up in the custom menu.

Steps to reproduce this bug:

  • Activate a theme with support for custom menus.
  • Under "Appearance" > "Menus", enable the option "Automatically add new top-level pages"
  • Create a new top-level page, and schedule it to be published in the future.
  • Wait for the page to be automatically published.

Change History (6)

comment:1 wonderboymusic2 months ago

  • Keywords needs-patch needs-unit-tests added
  • Milestone changed from Awaiting Review to 3.9

Let's take a look

comment:2 tlovett18 weeks ago

I'm unable to reproduce this. Environment/theme specific?

comment:4 ircbot5 weeks ago

This ticket was mentioned in IRC in #wordpress-dev by fadib. View the logs.

comment:5 fahmiadib5 weeks ago

[27556] fixed the issue

comment:6 nacin4 weeks ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.