WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#27654 closed defect (bug) (duplicate)

When installing plugins/ update WP: json_encode() recursion detected in update.php on lines 261 and 405

Reported by: RTalal Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Plugins Keywords:
Focuses: administration Cc:

Description (last modified by SergeyBiryukov)

When installing plugins (from wp interface), they are installed fine, but give warning. Example:

Installing Plugin: WordPress Importer 0.6.1
Successfully installed the plugin WordPress Importer 0.6.1.
Warning: json_encode() [function.json-encode]: recursion detected in /home/USER/public_html/test/wp-includes/update.php on line 261
Warning: json_encode() [function.json-encode]: recursion detected in /home/USER/public_html/test/wp-includes/update.php on line 405

In my installation (3.9-beta3-27857), line 261 in 3.9-beta3-27857:

	$url = set_url_scheme( $url, 'https' );

Line 405:

        $raw_response = wp_remote_post( $http_url, $options );

Maybe something has to do with ssl? I was logging in on ssl (https) (self-signed, if this matters).
I logged out and re-logged in with plain (http), but the same warnings appeared.

When updating wordpress, I get the same error. As it does not stay for long, I took a screenshot for it.

There is a similar warning for those same php lines in:
#27633 closed enhancement (fixed) , which is about UPRADING plugins or themes.

Notes:
Server:PHP 5.2.17, MySQL 5.5.36, Memory Usage 37,193,072 bytes

Site is right-to-left enabled, Arabic language enabled in wp-config.php, but wp language file is not uploaded.

Attachments (1)

warning-wpupdate.jpg (173.0 KB) - added by RTalal 6 years ago.
warning when upgradimg wp

Download all attachments as: .zip

Change History (3)

#1 @dd32
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27633.

This has already been fixed, but that fix isn't in the current nightly.
Should be right tomorrow.

@RTalal
6 years ago

warning when upgradimg wp

#2 @SergeyBiryukov
6 years ago

  • Component changed from Upgrade/Install to Plugins
  • Description modified (diff)
  • Focuses administration added
  • Type changed from enhancement to defect (bug)
Note: See TracTickets for help on using tickets.