WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#27663 closed defect (bug) (duplicate)

Updating Post Changes & to & in GUID

Reported by: tlovett1 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

Steps to reproduce bug:

  1. Create a new post with a GUID of http://test.com/?post_type=cpt&p=13

WP will encode the GUID as http://test.com/?post_type=cpt&p=13 in the DB

  1. Update the post through the post edit screen. Now view the GUID field in the database and it should be:

http://test.com/?post_type=cpt&p=13

This is a huge problem when keeping track of the uniqueness of a syndicated post using the GUID.

Change History (2)

#1 @tlovett1
5 years ago

  • Keywords needs-patch added

#2 @SergeyBiryukov
5 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from trunk to 2.5

Duplicate of #24248.

Note: See TracTickets for help on using tickets.