WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#27941 closed defect (bug) (fixed)

While resizing image in editor, dimensions no longer show

Reported by: justatest47 Owned by: azaozz
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords: has-patch
Focuses: ui, javascript Cc:

Description

Image scaling is shown as a new feature in Wordpress 3.9 yet I have been using image scaling for YEARS with Wordpress, in Firefox browser.

I don't know if this is a bug or something done deliberately but the new image scaling no longer shows image resolution while scaling. This is very frustrating, because this is affecting my work. I need to have a PRECISE control over resolution on my scaled pics (for perfect theme implementations) which are mostly hosted on image hosting services such as tinypic, imageshack, photobucket, etc

I hope my suggestion will be seriously considered and this feature be brought back.

Here's a screenshot from Wordpress 3.8.3 so you can see exactly what I'm talking about:

http://i58.tinypic.com/23kc5fr.jpg

Attachments (6)

Image-Scaling-Resolution.jpg (141.9 KB) - added by justatest47 4 years ago.
27941.patch (1.8 KB) - added by iseulde 4 years ago.
27941.2.patch (1.8 KB) - added by iseulde 4 years ago.
Screen Shot 2014-05-25 at 20.18.14.png (49.9 KB) - added by iseulde 4 years ago.
Creates a helper on the bottom right of the mouse.
27941.3.patch (2.2 KB) - added by azaozz 4 years ago.
27941.4.patch (2.2 KB) - added by iseulde 4 years ago.

Download all attachments as: .zip

Change History (35)

#1 follow-up: @SergeyBiryukov
4 years ago

Confirmed. This is also mentioned in #27932.

#2 in reply to: ↑ 1 @justatest47
4 years ago

Replying to SergeyBiryukov:

Confirmed. This is also mentioned in #27932.

That's great! So I guess next version 3.9.1 will bring back this feature, right?

When will 3.9.1 come out? I'm really having a hard time posting in 3.9 without the image resolution being shown.

Thanks

#3 follow-up: @nacin
4 years ago

  • Milestone changed from Awaiting Review to 3.9.1

There's no timeline yet for 3.9.1 and there's no guarantee we'd bring this back, but moving to 3.9.1 for investigation.

#4 follow-ups: @iseulde
4 years ago

This is a feature added for contenteditable in Firefox which is disabled by TinyMCE to use its own resizing. I've asked Spocke about it.

#5 in reply to: ↑ 3 @justatest47
4 years ago

Replying to nacin:

There's no timeline yet for 3.9.1 and there's no guarantee we'd bring this back, but moving to 3.9.1 for investigation.

But this has to be brought back one way or another! It's a must-have feature!

It's simply unworkable under these circumstances, what is Wordpress coming to? Simplism over a complex and useful platform? Simplism worked for Apple iPhones for a while but now look at the stats. Android which is a complex platform is spanking Apple like a grown up spanking its naughty child, with Android having more than 80% world market share and Apple only a tiny fraction...

Why would Wordpress want to become simplistic and dumbed down? Competition would then pose a threat to Wordpres... don't let this happen, it would be a pity, as Wordpress has always been a fantastic platform.

#6 in reply to: ↑ 4 ; follow-up: @justatest47
4 years ago

Replying to avryl:

This is a feature added for contenteditable in Firefox which is disabled by TinyMCE to use its own resizing. I've asked Spocke about it.

Ok I get it, but at least someone should edit TinyMCE and make it show the resolution while scaling. You can't just randomly scale a photo to a "whatever" resolution......

We need to scale it to PRECISE resolutions.

Or at least could you teach me how to disable this feature in Wordpress 3.9? It's really annoying me...

#7 in reply to: ↑ 4 @nacin
4 years ago

  • Milestone changed from 3.9.1 to 3.9.2

Replying to avryl:

This is a feature added for contenteditable in Firefox which is disabled by TinyMCE to use its own resizing. I've asked Spocke about it.

Good to know. Makes sense as to why I hadn't seen this before.

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.


4 years ago

#9 @thinkwired
4 years ago

+1 on showing image dimensions on resize.

#10 in reply to: ↑ 6 ; follow-up: @ericlewis
4 years ago

  • Focuses ui added

Replying to justatest47:

We need to scale it to PRECISE resolutions.

If you have precise resolutions, switch the editor to Text mode and set the width and height attributes on the <img>.

Is this a common use case? Should we add control to this in the "Edit Image details" modal (after clicking the pencil on an image in TinyMCE)? This used to be available pre-3.9 in the former modal.

#11 in reply to: ↑ 10 ; follow-up: @SergeyBiryukov
4 years ago

Replying to ericlewis:

Is this a common use case? Should we add control to this in the "Edit Image details" modal (after clicking the pencil on an image in TinyMCE)? This used to be available pre-3.9 in the former modal.

Just saw a request for bringing back the size controls on support forums today. If we don't want to do that in core, I think they should be added to the Advanced Image Styles plugin.

#12 @ericlewis
4 years ago

  • Summary changed from Image Scaling Resolution No Longer Shown in Wordpress 3.9 to While resizing image in editor, dimensions no longer show

#13 @SergeyBiryukov
4 years ago

  • Component changed from Media to TinyMCE

#14 @SergeyBiryukov
4 years ago

#28358 was marked as a duplicate.

#15 @magdigit
4 years ago

I don't know what TinyMCE is, but personally I think it's stupid to go back to html-editor for every mm you want to resize, and then go back again to WYSIWYG-editor to resize te next mm you're looking for.

And the idea for a plugin for this tiny wonder-window is just hilarious. Please bring back that tiny unmissable help!

I am new to this, so forgive me when I don't understand all the code-talking.

@iseulde
4 years ago

#16 @iseulde
4 years ago

  • Focuses javascript added
  • Keywords has-patch needs-testing added

The patch is kind of hacky, but it works. Maybe I should make a patch for TinyMCE, that would be cleaner... Also not sure if the helper should be attached to the iframe's body or parent body.

@iseulde
4 years ago

#17 follow-ups: @iseulde
4 years ago

.2 attaches the the helper to the iframe's body instead. Again, not sure what's best...

@iseulde
4 years ago

Creates a helper on the bottom right of the mouse.

#18 in reply to: ↑ 17 @magdigit
4 years ago

Replying to avryl:

.2 attaches the the helper to the iframe's body instead. Again, not sure what's best...

Dear Avryl!

Wow, quite a job you did! The png shows indeed exactly what we need!!

But, as I am an illustrator from the former century who only managed to build a platform to publish her work, I really don't have the knowledge of developping/coding etc. In the course of this issue I just learnt for the first time what a TinyMCE is AND that this wonder-editor broke exactly at the release of WP3.9, when this helper disappeared from WP 3.9.

So the 'patch.2' you provided so friendly, I really have no clue where to place it! I guess I will not be the only WP-user.

I hope the WP-develop-wondercrew would reconsider to put this helper back in their own editor again.

Thank you so much anyway, Avryl! Best wishes from Amsterdam

@azaozz
4 years ago

#19 in reply to: ↑ 17 @azaozz
4 years ago

Replying to avryl:

It can be either.

Looks very good, 27941.3.patch only replaces clientX/Y with pageX/Y and adds data-mce-bogus to the dimensions div so it's removed on getContent().

@iseulde
4 years ago

#20 follow-up: @iseulde
4 years ago

  • Keywords needs-testing removed

Thank you! :) Just the styling of the box will need to be reset a bit if added to the iframe, so it's the same with any theme. I set the font and line height to 14px, and the family to open-sans. It's probably not worth loading open sans for that.

#21 in reply to: ↑ 20 ; follow-up: @magdigit
4 years ago

Replying to avryl:

Thank you! :) Just the styling of the box will need to be reset a bit if added to the iframe, so it's the same with any theme. I set the font and line height to 14px, and the family to open-sans. It's probably not worth loading open sans for that.

Is this dumbo allowed to ask if these patches will be embedded in the next WP-editor (version 4.0)? Because I don't know where to put all these codes myself. And I really want that nice scaling-helper!

Thankful greetings from rainy Amsterdam, Magda

#22 in reply to: ↑ 21 ; follow-up: @iseulde
4 years ago

Replying to magdigit:

This ticket's milestone is 3.9.2, so it would be considered to be included then I think.

#23 in reply to: ↑ 22 @magdigit
4 years ago

Replying to avryl:

Replying to magdigit:

This ticket's milestone is 3.9.2, so it would be considered to be included then I think.

Oh wow, I will look greedily forward to that! Thank you so much, masterbrains! I shall no longer intrude in Ops ;-)

#24 @azaozz
4 years ago

This was added upstream (props avryl) together with some other image resizing enhancements: https://github.com/tinymce/tinymce/commit/43fff5b45344e0101d7d75d8e3c01e9758f0d20f.

#25 @azaozz
4 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 28606:

TinyMCE: update to 4.0.28. Also includes https://github.com/tinymce/tinymce/commit/43fff5b45344e0101d7d75d8e3c01e9758f0d20f. Part-props avryl for the patch on #27941, fixes #28391, #27941.

#26 @SergeyBiryukov
4 years ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

#27 in reply to: ↑ 11 @bkjproductions
4 years ago

I have several WP users who are complaining about the loss of the height/width fields on "Edit Image details". Oddly, if you are editing the details of an image that was uploaded to WordPress, you can type in the height/width. If the image is an external URL (for example, from Flickr) you can NOT type in the height/width. It does not make sense that you're allowed to do one and not the other. (If you are going to do something "special" for the external URL images, it would be ideal to display the height/width information for that.)

Displaying the height/width while dragging is a great idea, especially if the styling is matching the other interface elements' tooltips. That may be an adequate workaround for my users.

Can the size controls be put back in for BOTH internal and external images? Thanks for your consideration.

Replying to SergeyBiryukov:

Replying to ericlewis:

Is this a common use case? Should we add control to this in the "Edit Image details" modal (after clicking the pencil on an image in TinyMCE)? This used to be available pre-3.9 in the former modal.

Just saw a request for bringing back the size controls on support forums today. If we don't want to do that in core, I think they should be added to the Advanced Image Styles plugin.

#28 @magdigit
4 years ago

May I ask, as a WPuser, WHY this utterly usefull scaler suddenly was deleted in the first place?

#29 @azaozz
4 years ago

  • Keywords fixed-major removed
  • Milestone changed from 3.9.2 to 4.0
  • Resolution set to fixed
  • Status changed from reopened to closed

No point in updating to an "interim" version. WordPress 4.0 includes TinyMCE 4.1+ and will be out soon.

Note: See TracTickets for help on using tickets.