WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#28431 closed defect (bug) (duplicate)

There's no way to close the "keyboard shortcuts" modal with the keyboard

Reported by: iseulde Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: TinyMCE Keywords:
Focuses: ui, accessibility, javascript Cc:

Description

Quite an ironic bug.

When you open the "help" modal with alt + shift + H, there's no way to close it with the keyboard. Using the same shortcut opens *another* modal over the old one. Esc doesn't work. Then I close the modal with the mouse, but the first one remains open (so it looks like nothing closed...). Clicking on it again finally closes everything.

Change History (5)

#1 @iseulde
7 years ago

A keyboard user trap. :)

#3 @afercia
6 years ago

  • Focuses ui accessibility javascript added
  • Version set to 4.0

See also discussion on #27642 about the content of the modal. It probably needs a complete refresh.

#4 @iseulde
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27642.

#5 @iseulde
6 years ago

Fixed in [30757].

Note: See TracTickets for help on using tickets.