WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28730 closed defect (bug) (fixed)

Installing British English language files removes the ability to select American English on Multisite

Reported by: johnbillion Owned by: ocean90
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.0
Component: I18N Keywords:
Focuses: multisite Cc:

Description

Multisite provides a 'Site Language' dropdown on the General Settings screen if you've installed any language files.

If you install British English (en_GB) then the logic in mu_dropdown_languages() prevents the default English (ie. American English) option from showing up.

I guess if you're a particularly patriotic Brit then this could be seen as a feature rather than a bug, but hey, we should fix it either way.

Attachments (1)

28730.diff (1.6 KB) - added by johnbillion 6 years ago.

Download all attachments as: .zip

Change History (8)

@johnbillion
6 years ago

#1 @johnbillion
6 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 4.0

#2 @iandunn
6 years ago

I think that entire function is getting replaced in 4.0 with something that can handle language variants better.

related #28577, #15677, http://make.wordpress.org/core/2014/07/02/internationalization-project-updates/

#3 @netweb
6 years ago

  • Keywords has-patch removed

Below the fold is what I was going to submit, then I looked at the source in /wp-admin/includes/ms.php and saw 'British English' is hard coded, whereas other English variants are not, so basically ignore what I have written below though for context I think it is kind of relevant ;)

I do believe as Ian suggested this will be looked at for the internationalisation goals for 4.0 and should address your issue you described and also take into account and how I see two 'English' select fields in the dropdown with no discernible difference of which English version is which (without viewing the source code).


Technically, I cannot reproduce this, though I see where you are coming from John.

Just on the English side of things this also occurs for en_AU English (Australia) and presumably en_CA English(Canada)

https://i.cloudup.com/Oiwgw-hnME.png

I have a dropdown with two 'English' select fields, one is en_AU and the other is the default en_US.

The HTML source of the dropdown

<tr>
  <th width="33%" scope="row">Site Language</th>
  <td>
    <select name="WPLANG" id="WPLANG">
      <option value="" selected="selected">English</option>
      <option value="en_AU"> English</option>
    </select>
  </td>
</tr>

Switching between them correctly switches language from en_AU to en_US

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.


6 years ago

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.


6 years ago

#6 @ocean90
6 years ago

15677.6.patch:ticket:15677 from #15677 replaces mu_dropdown_languages() with wp_dropdown_languages().

#7 @ocean90
6 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 29630:

Language packs: No WPLANG anymore.

  • The WPLANG constant is no longer needed. Remove define('WPLANG', ); from wp-config-sample.php. Populate WPLANG option based on the WPLANG constant. When get_option('WPLANG') is an empty string it will override WPLANG.
  • Introduce translations_api() which is available to communicate with the translation API. Move translation install related functions to a new file.
  • Replace mu_dropdown_languages() with wp_dropdown_languages(). wp_dropdown_languages() is now populated by the translation API.
  • Remove wp_install_load_language() and allow load_default_textdomain() to switch a core translation.

fixes #13069, #15677, #19760, #28730, #29281.

Note: See TracTickets for help on using tickets.