WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28953 closed enhancement (duplicate)

No means of retrieving a users admin color scheme

Reported by: welcher Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords:
Focuses: ui, administration Cc:

Description

I was creating a plugin and wanted the layout to mirror the user's color scheme. I know there are classes available as mentioned in #26691 and #28324, but some of the colors don't seem to be reference there.

I found no (quick) way to access the information for the color scheme registered with wp_admin_css_color().

Attachments (1)

28953.diff (1.0 KB) - added by welcher 6 years ago.

Download all attachments as: .zip

Change History (5)

@welcher
6 years ago

#1 @SergeyBiryukov
6 years ago

  • Focuses ui added

#2 @SergeyBiryukov
6 years ago

  • Focuses administration added

#3 @nacin
6 years ago

  • Version changed from trunk to 3.8

What would the use case be for this? See also #28324 which mentions that helper classes exist.

These registered colors are only useful for showing a palette and for the icon colors. They shouldn't be indicative of specific primary/secondary colors, so I'm not sure having a function for them would be a great idea.

#4 @nacin
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28324.

Note: See TracTickets for help on using tickets.