WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#28968 closed defect (bug) (wontfix)

Twenty Fourteen: Flips to Tablet Mode Too Soon

Reported by: Quantumstate Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Bundled Theme Keywords: needs-patch
Focuses: Cc:

Description

The left widgets panel in 2014 drops to the bottom of the screen too soon. (switches to tablet mode) There's plenty of margin on both sides of the entry. See attachment.

If this won't be fixed (margins reduced) please tell me how to fix it.

Attachments (3)

snap.png (190.5 KB) - added by Quantumstate 5 years ago.
Giant margins
image.png (512.0 KB) - added by Quantumstate 5 years ago.
portrait
image2.png (500.0 KB) - added by Quantumstate 5 years ago.
landscape

Download all attachments as: .zip

Change History (17)

@Quantumstate
5 years ago

Giant margins

#1 @SergeyBiryukov
5 years ago

  • Component changed from Themes to Bundled Theme
  • Summary changed from 2014 Flips to Tablet Mode Too Soon to Twenty Fourteen: Flips to Tablet Mode Too Soon

#2 follow-up: @Quantumstate
5 years ago

Ok so setting in style.css, line 3602 to
@media screen and (min-width: 1000px) {

... makes me happy with Firefox. But my son is looking at it on his iPad in landscape, and the left bar is at the bottom, although there's plenty of room for it in the width of the screen. In landscape there should be that left widget bar, and maybe in portrait too.

Further, the title bar stays at the top as I scroll down in Firefox, but disappears on his iPad. Should I file another bug for this? Hasn't anyone checked these things?

#3 @lancewillett
5 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

We've put hours and hours into Twenty Fourteen, but yes -- sometimes we miss things. :) Only human.

Also worth remembering that "broken" to you might be something that is that way by design, intentionally left as-is because of other trade-offs. It'll depend on the situation, of course.

Thanks for reporting and keep them coming if you see other things -- but please put one bug per ticket so we can work on them separately.

#4 in reply to: ↑ 2 @celloexpressions
5 years ago

Replying to Quantumstate:

Further, the title bar stays at the top as I scroll down in Firefox, but disappears on his iPad. Should I file another bug for this? Hasn't anyone checked these things?

That's intentional - the header bar is only fixed on larger screens so that it doesn't take up too much space on smaller devices.

I'm guessing you're seeing all of the margin since you aren't using the content sidebar. Twenty Fourteen drops the primary (left) sidebar first, then keeps the content sidebar around on much smaller devices before dropping it below. Floated images go into the margins here when there is no content sidebar. We could potentially do something here where we keep the primary sidebar on the side on smaller devices when there is no content sidebar.

#5 @Quantumstate
5 years ago

What I'm saying though is that my son says there's still plenty of room in the margins on his iPad in landscape, but the sidebar drops. And he complained that the header bar went away when he scrolled.

Seems to me that the theme should test for landscape or portrait, and if portrait drop the left sidebar. Happens way too soon on larger tablets.

#6 @Quantumstate
5 years ago

Looks like no one's going to do anything about this, but at least I'm fixed. On the iPad now there is the left bar in both landscape and portrait, with no apparent ill effects. (attachments)

Evidently the default settings bother no one but me.

@Quantumstate
5 years ago

portrait

@Quantumstate
5 years ago

landscape

#7 follow-up: @Quantumstate
5 years ago

I give up. None of my other 4 or so tickets have even been approved from moderation, so y'all don't care. Making suggestions has been a waste of time. At least I'm fixed.

#8 @celloexpressions
5 years ago

#29681 was marked as a duplicate.

#9 @Quantumstate
5 years ago

Absolutely nothing has been done on this ticket, and it's clear that nothing will be done.

Ditching twenty fourteen as it's busted.

#10 @Kelderic
5 years ago

#29681 was marked as a duplicate.

#11 in reply to: ↑ 7 @SergeyBiryukov
5 years ago

Replying to Quantumstate:

I give up. None of my other 4 or so tickets have even been approved from moderation, so y'all don't care.

Not sure what you mean, both #28967 and this ticket were marked as needs-patch and moved to Future Release.

If this won't be fixed (margins reduced) please tell me how to fix it.

If you need help implementing a workaround, please continue with your topic on support forums, I've replied there:
http://wordpress.org/support/topic/theme-twentyfourteen-left-sidebar-drops-to-bottom

#12 @knutsp
5 years ago

I have used Twenty Fourteen as the basis in a quite large project in a multisite, all sites using the same theme with some differences, as colors etc. First thing was to create a child theme, then adding a body class identifying each site. Next thing was to combat some strange behaviour on some smaller screens. Nothing that couldn't be done, but there was some struggles, pushing us to the limits of our CSS knowledge. We are all happy now.

I definitely don't think "busted" is the right word here, under any circumstance.

  1. You never ever edit an updateable theme, especially not a core bundeled theme
  2. You need some extra skills to be able to override a theme using a child theme. Overriding CSS media queries is especially difficult, but not undoable
  3. If you need help, use the support forums until you actually have a real bug to present
  4. Your problems doing what you want to do does not implicate there has to be a bug in the software you are using. But there may very well be a suggestion for an enhancement to make every developers tasks easier.
  5. This ticket is going to have a resolution some day. One must have some patience. In the mean time you have to find a fix yourself. That's life.

#13 @Quantumstate
5 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Never mind. I've found a far more advanced solution.

#14 @DrewAPicture
5 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.