WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#29626 closed enhancement (duplicate)

Ability to set ABSPATH to something else then the directory where wp-load.php is

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bootstrap/Load Keywords:
Focuses: Cc:

Description

I think that it is really a regression, but since it is probably happened long ago I might as well call it an enhancement now.

I want to be able to set ABSPATH to

$_SERVER['document_root']

which will help me with some complex symlink games I am trying to play, but there is no way to do that as ABSPATH is unconditionally defined in wp-load.php.

BTW wp-config-sample.php still includes code that defines ABSPATH.

Change History (3)

#1 @SergeyBiryukov
6 years ago

  • Component changed from General to Bootstrap/Load

#2 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26592.

#3 @nacin
6 years ago

wp-config-sample.php includes code that defines ABSPATH for plugins and implementations directly including wp-config.php, which was the "right" way before wp-load.php existed. (Of course, it is never the right way for plugins, but there are some cases where you want to include wp-load.php to do things.) It's purely for back compat at this point.

Note: See TracTickets for help on using tickets.