WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#30001 closed defect (bug) (worksforme)

U+FEFF at start of fields crash Chrome

Reported by: mikenolan Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Formatting Keywords: close
Focuses: Cc:

Description (last modified by TobiasBg)

Came across this earlier in the week on the same day as we found #30005. Also only happens in Twenty Twelve.

If a U+FEFF character appears at the start of the title of a post then viewing the post will crash Chrome (and Opera):

https://drive.google.com/file/d/0B-rPZ6460XuzTGVLTEcybEM1eUU/view?usp=sharing

It only happens if the character is at the start of the title and also happens with other fields such as excerpt on pages where that text is shown (e.g. search results pages)

Can also reproduce on WordPress.com (this will crash your browser tab in Chrome!!):

http://mikenolan.wordpress.com/ufeff-bug/

One of our servers (running a different version of PHP but same version of WordPress and Twenty Twelve theme) replaces the U+FEFF character with a question mark and pages load fine.

Change History (6)

#1 @TobiasBg
7 years ago

  • Description modified (diff)

#2 @DrewAPicture
7 years ago

  • Component changed from General to Formatting

#3 follow-up: @miqrogroove
7 years ago

You should report your bug at https://code.google.com/p/chromium/issues/list

Is there any reason to track this as a WordPress defect?

#4 in reply to: ↑ 3 @mikenolan
7 years ago

Replying to miqrogroove:

You should report your bug at https://code.google.com/p/chromium/issues/list

Is there any reason to track this as a WordPress defect?

I submitted a bug report in Chrome yesterday as well.

While the crash may be caused by Chrome, maybe it's not a good idea for BOM characters to be allowed at the start of strings stored by WP?

http://www.unicode.org/faq/utf_bom.html#bom6

#5 @azaozz
7 years ago

  • Keywords close added

Tried to reproduce in Chrome 38.0.2125.101 m (Win7, 64). No crash when accessing the above URL. While testing, Chrome updated itself to 38.0.2125.104 m which also worked properly.

Looks like a bug that got fixed.

#6 @wonderboymusic
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Marked close 11 months ago, bug appears to be fixed in Chrome as per comment:5

Note: See TracTickets for help on using tickets.