WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#30005 closed defect (bug) (worksforme)

Making text bold then typing crashes Chrome

Reported by: mikenolan Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: TinyMCE Keywords: reporter-feedback
Focuses: Cc:

Description

Getting a pretty obscure bug with TinyMCE in certain situations. Turning on bold text either with the toolbar button or Ctrl-B then starting to type, Chrome 38 will crash with the first keystroke.

It's possibly a Chrome issue - it's only come to light with Chrome 38 released last week and isn't (currently) happening with Chrome Canary 40, however it's only happening in WordPress, not with straight TinyMCE and most notably, only when using the Twenty Twelve theme (or children of it).

Here's the bug in action:

https://drive.google.com/file/d/0B-rPZ6460XuzOHFseHNaYmNpa00/view?usp=sharing

I'm almost certain it has something to do with the U+FEFF (ZERO WIDTH NO-BREAK SPACE / BYTE ORDER MARK) character that gets inserted when bold text is turned on as they cause crashes in the frontend of WordPress sites as well.

Just tried latest stable version of Opera and it crashes that too.

Change History (5)

#1 @iseulde
7 years ago

I can't reproduce in Chrome 38.0.2125.101 with Twenty Twelve activated.

#2 @mikenolan
7 years ago

A few more details about the environment(s) where I'm seeing this error.

Windows 7 64 bit PC running

  • Chrome 38.0.2125.104 (32 bit version)
  • Opera 25.0.1614.50 (32 bit)

Android 4.4.4

  • Chrome for Android 38.0.2125.102

These were tested using a Twenty Twelve site running on WordPress.com to eliminate our server environment.

I'm pretty sure this is a similar issue to #30001.

#3 @azaozz
7 years ago

  • Keywords reporter-feedback added

Testing in Chrome 38.0.2125.104 m on Win7, not able to reproduce it either. TinyMCE pads empty inline nodes with U+FEFF so the caret can be placed there (bugfix for contentEditable). That's not new, has been used for years.

This bug is most likely triggered by the styles added by Twenty Twelve. If you can isolate which one triggers it, we can find a workaround.

Last edited 7 years ago by azaozz (previous) (diff)

#4 @iseulde
7 years ago

Hi @mikenolan,

Are you still experiencing this issue with Chrome 39?

#5 @iseulde
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No feedback in 3 months and no similar reports.

Note: See TracTickets for help on using tickets.