WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#31969 closed defect (bug) (duplicate)

Updater flags custom theme that doesn't match theme name at WordPress.org

Reported by: novasource Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Themes Keywords:
Focuses: Cc:

Description

We have a theme named smumagazine-staging. It is a child theme of iMagPress Premium Theme 1.0.4. This theme is on a WordPress Network.

For some reason, the updater flags smumagazine-staging as needing an update to version 0.3.2. This is impossible as there is no theme at WordPress.org with this name.

When I go to /wp-admin/network/themes.php and find this theme, the View version 0.3.2 details link takes me to https://wordpress.org/themes/magazine/, which is a child theme of the Omega theme.

Here's the complete style.css from our smumagazine-staging theme:

/*

Theme Name: smumagazine-staging
Template: imagpress-themes
*/

@import url("/wp-content/themes/imagpress-themes/style.css");


body #sidebar ul.kebo-tweets, body #widgets ul.kebo-tweets {
    padding: 20px !important;
}

Change History (2)

#1 @SergeyBiryukov
5 years ago

  • Component changed from Upgrade/Install to Themes
  • Milestone changed from Awaiting Review to WordPress.org
  • Summary changed from Updater flags custom theme that doens't match theme name at WordPress.org to Updater flags custom theme that doesn't match theme name at WordPress.org

Related: #14179, #23318.

#2 @dd32
5 years ago

  • Milestone WordPress.org deleted
  • Resolution set to duplicate
  • Status changed from new to closed

WordPress is detecting the update based on the theme directory name, not the theme name itself. Use a unique folder name and you'll be fine.

Marking as a duplicate of #14179

Note: See TracTickets for help on using tickets.