WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 22 months ago

#32270 closed defect (bug) (wontfix)

Update Core updates translations when updating plugin or theme

Reported by: MattyRob Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.1
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

The update-core.php page not only updates the core WordPress files but is also a point for updating plugins, themes and translation files.

I've noticed that if there is a plugin or theme that needs updating and there is also a translation file that needs updating, updating the plugin / theme also updates the translation file even though I may well not have wanted that update processing.

Either the plugin / theme / translation updates need to be removed from this section, or translation files should not be updated unless the user actually agrees to the update.

Change History (5)

#1 @ocean90
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

That's by design. Translation updates should happen in background. But there is a filter to disable async updates: async_update_translation.

See #28571 for background.

#2 @MattyRob
6 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Thanks for clarifying that but I have the following in the plugin on my site:

add_filter( 'auto_update_core', '__return_false' );
add_filter( 'auto_update_plugin', '__return_false' );
add_filter( 'auto_update_theme', '__return_false' );
add_filter( 'auto_update_translation', '__return_false' );

I want total control over all updates that are applied.

The by design function of the update-core.php countermands the above filters and updates a translation when I want a plugin or theme updated. That's not a great user experience.

Last edited 22 months ago by SergeyBiryukov (previous) (diff)

#3 @ocean90
6 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

That was a design decision. The auto_update_ filters don't make sense in this case because it's not an auto update, it's an async update. If you want to have "total control" then you have to use the async_update_translation filter too.

#4 @MattyRob
6 years ago

@ocean90

Thanks for the additional explanation - I understand it more now.

I've applied a 'fix' on my sites for my own satisfaction using the filter you suggested.

I wonder if the translation update button should show if there are theme or plugin updates also - wouldn't it make more send to only show the button if an update is available for a translation file when the async_update_translation filter is true and there are no updates for plugins and themes available?

#5 @SergeyBiryukov
22 months ago

#48806 was marked as a duplicate.

Note: See TracTickets for help on using tickets.