#32435 closed defect (bug) (fixed)
error messages returned by auth modal when trying to update a plugin lack detail
| Reported by: | TerraFrost | Owned by: | dd32 |
|---|---|---|---|
| Priority: | normal | Milestone: | 4.2.3 |
| Component: | Upgrade/Install | Version: | |
| Severity: | normal | Keywords: | fixed-major |
| Cc: | Focuses: |
Description
If you try to update a plugin and encounter an error via the auth modal you'll get a generic "Unable to connect to the filesystem. Please confirm your credentials." instead of a more detailed and more helpful error message like any of the ones wp-admin/includes/class-wp-filesystem-ssh2.php actually generates. eg.
- Failed to connect to SSH2 Server %1$s:%2$s
- Username/Password incorrect for %s
- Public and Private keys incorrect for %s
This is because the bulk_upgrader method in wp-admin/includes/class-wp-upgrader.php returns a false rather than the actual error. Two other changes need to be made for it to work as detailed in the attached patch.
Attachments (1)
Change History (15)
Note:
See TracTickets
for help on using tickets.
![(please configure the [header_logo] section in trac.ini)](/chrome/site/your_project_logo.png)
patch fixing this issue