WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#33778 closed defect (bug) (fixed)

Password label not focussing password field when clicked

Reported by: umesh.nevase Owned by: adamsilverstein
Milestone: 4.3.1 Priority: normal
Severity: major Version: 4.3
Component: Administration Keywords: has-patch needs-testing
Focuses: ui, accessibility, javascript, administration Cc:

Description

When we click on password label on wordpress install page, the password text field not getting focussed. When we click on hide button and then click on 'Password' label then the password text field gets focussed. It is little bit confusing the user, whether to edit or not the password.

Attachments (7)

install-edited.png (54.5 KB) - added by umesh.nevase 4 years ago.
Password label is not working
33778.patch (1006 bytes) - added by umesh.nevase 4 years ago.
patch file for the issue, I've made changes in user-profile.js
33778.2.patch (1.3 KB) - added by umesh.nevase 4 years ago.
Fixed issue for user edit and add new user page. This is working latest patch
33778.3.patch (3.4 KB) - added by umesh.nevase 4 years ago.
same issue also exists on New user and Edit profile pages. I've added id and script that handled the issue for all ( Install.php, user-new.php, profile.php ) password label
33778.4.patch (3.7 KB) - added by umesh.nevase 4 years ago.
handled issue after canceling the password, when user clicks on 'cancel' button label for attribute set to wp-generate-pw
33778.5.patch (3.2 KB) - added by umesh.nevase 4 years ago.
if javascript disabled handled password label to set 'pass1' focus and previous issue patch and this is final patch
33778.6.patch (3.1 KB) - added by azaozz 4 years ago.

Download all attachments as: .zip

Change History (27)

@umesh.nevase
4 years ago

Password label is not working

@umesh.nevase
4 years ago

patch file for the issue, I've made changes in user-profile.js

#1 @umesh.nevase
4 years ago

  • Keywords has-patch added

#2 @joedolson
4 years ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 4.3.1
  • Severity changed from normal to major

This seems like a pretty major bug that needs to go into 4.3.1. Thanks for reporting!

@umesh.nevase
4 years ago

Fixed issue for user edit and add new user page. This is working latest patch

#3 @umesh.nevase
4 years ago

I've added new patch ( 33778.2.patch ) which is also works on user edit and add new user page. I've found the same issue on User edit page and Add new user page.

#4 @adamsilverstein
4 years ago

@umesh.nevase:

Thanks for the bug report and patch.

This makes sense as we are swapping fields and need to keep track of where the focus should go. I will give this patch a test.

#5 @adamsilverstein
4 years ago

  • Summary changed from Wordpress install password label not focussin password field on click to Password label not focussing password field when clicked

#6 follow-up: @adamsilverstein
4 years ago

  • Owner set to adamsilverstein
  • Status changed from new to assigned

#7 in reply to: ↑ 6 @juhise
4 years ago

Replying to adamsilverstein:

Already reported. Seems similar to https://core.trac.wordpress.org/ticket/33647

Last edited 4 years ago by juhise (previous) (diff)

@umesh.nevase
4 years ago

same issue also exists on New user and Edit profile pages. I've added id and script that handled the issue for all ( Install.php, user-new.php, profile.php ) password label

#8 @umesh.nevase
4 years ago

@juhise I've seen same issue also exists on 'User profile' and 'New user' page. I added id field for 'Generate Password' button and added script to handle these issue. I've created new patch 33778.3.patch for all the issues ( install.php, pofile.php, user-new.php)

Last edited 4 years ago by umesh.nevase (previous) (diff)

@umesh.nevase
4 years ago

handled issue after canceling the password, when user clicks on 'cancel' button label for attribute set to wp-generate-pw

@umesh.nevase
4 years ago

if javascript disabled handled password label to set 'pass1' focus and previous issue patch and this is final patch

#9 @adamsilverstein
4 years ago

@umesh.nevase: Thanks for the updated patch, I will test!

This ticket was mentioned in Slack in #core-passwords by sam. View the logs.


4 years ago

#11 follow-up: @azaozz
4 years ago

Looking at 33778.5.patch: it "points" the label to the Show password button. However clicking on a label for a button is pretty much the same as clicking the button. Do we want that behavior?

@azaozz
4 years ago

#12 @azaozz
4 years ago

In 33778.6.patch:

  • Better caching and reusing of selected elements.
  • Fixed formatting.

It still includes the label pointing to a button parts.

This ticket was mentioned in Slack in #core by azaozz. View the logs.


4 years ago

#14 in reply to: ↑ 11 @afercia
4 years ago

Replying to azaozz:

it "points" the label to the Show password button. However clicking on a label for a button is pretty much the same as clicking the button. Do we want that behavior?

I'd recommend to avoid that, it's unexpected behavior and pretty confusing for all users.

#15 @azaozz
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 34061:

Settings: reassign the label when switching password fields so it always highlights the visible field.

Props umesh.nevase.
Fixes #33778 for trunk.

#16 @azaozz
4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopen for 4.3.

#17 @azaozz
4 years ago

In 34062:

Settings: properly set the password field label on loading.

See #33778.

#18 follow-up: @azaozz
4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 34063:

Settings: reassign the label when switching password fields so it always highlights the visible field.

Props umesh.nevase.
Fixes #33778 4.3.

This ticket was mentioned in Slack in #core by juhisaxena. View the logs.


4 years ago

#20 in reply to: ↑ 18 @umesh.nevase
4 years ago

Replying to azaozz:

In 34063:

Settings: reassign the label when switching password fields so it always highlights the visible field.

Props umesh.nevase.
Fixes #33778 4.3.

@azaozz

I hope we also fixed same issue for 'User profile' and 'New user' page.
I had added patch in 33778.5.patch​ for the issue of this pages. because I could not see changes for profile page and new user page in commit or changeset 34061, 34062 and 34063.

Should I create new ticket for this issues?

Last edited 4 years ago by umesh.nevase (previous) (diff)
Note: See TracTickets for help on using tickets.