WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#41005 closed defect (bug) (duplicate)

VideoPress oEmbed not working

Reported by: ahortin Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Embeds Keywords:
Focuses: Cc:
PR Number:

Description

I've just tried to share the Link Boundaries VideoPress vid from the WP4.8 announcement and I've found that the VideoPress oEmbed doesn't work.

This is the video I'm referring to: https://videopress.com/v/8BDWH3QG

VideoPress oEmbed support was supposedly added back in WordPress 4.4 (ticket #34031) but I've just tried every major WP version from 4.4 through to 4.8, using default WordPress themes, and it didn't work in any version.

I've also tried with no plugins activated, using both Firefox and Chrome.

Change History (4)

#1 @dd32
3 years ago

It looks like the oEmbed API endpoint we've hardcoded for VideoPress isn't returning the correct data.

For example:
https://public-api.wordpress.com/oembed/1.0/?for=http%3A%2F%2Ftestbox%2Fwordpress-develop%2Fsrc&maxwidth=525&maxheight=788&url=https%3A%2F%2Fvideopress.com%2Fv%2F8BDWH3QG&format=json

I'm chasing this up internally at Automattic to see why. Looks like it's been out of action since late May.

Although this isn't a bug in WordPress as such, I'll leave this ticket open until it's fixed.

#2 @swissspidy
3 years ago

@dd32 Looks like the oEmbed endpoint for VideoPress is now https://public-api.wordpress.com/oembed/1.0/embed/ and not https://public-api.wordpress.com/oembed/1.0/. I guess that changed when they switched to the WP REST API.

#3 @dd32
3 years ago

Yeah, this is because the 4.8 oEmbed rules were added.

Switching to https://public-api.wordpress.com/oembed/ works, but something should be added wp.com-side so that we don't need to.

#4 @dd32
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This has been fixed on WordPress.com's side.

#41019 is a follow up to switch to the new URL, whereas the URL here is now deprecated and for back-compat only.

Marking as a duplicate of #41019 since nothing was changed in core here, and it's a clearer ticket for going forward.

Note: See TracTickets for help on using tickets.