WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 7 weeks ago

#41729 closed enhancement (duplicate)

Code Editors: Better design for folders

Reported by: melchoyce Owned by:
Milestone: Priority: high
Severity: normal Version:
Component: Administration Keywords: ui-feedback needs-patch
Focuses: ui, accessibility Cc:

Description

This is related to (and relies on) #6531.

Let's make the file list easier to scan and introduce a way to collapse folders. See attached mockup.

Attachments (2)

File Structure.png (41.5 KB) - added by melchoyce 3 months ago.
File Structure v2.png (41.9 KB) - added by melchoyce 2 months ago.

Download all attachments as: .zip

Change History (16)

This ticket was mentioned in Slack in #core-customize by melchoyce. View the logs.


3 months ago

#2 @afercia
3 months ago

  • Focuses accessibility added

and introduce a way to collapse folders

Adding the accessibility focus because any UI component that is not "native" in HTML and that is implemented as a sort of "widget" with non-standard semantics and interaction needs some special accessibility treatment. Assistive technologies, and people using them, need to understand how a special "widget" works to be able to use it.

Seems to me this should be implemented as an ARIA "Tree View". More details, expected keyboard interaction, and examples available on the ARIA Authoring Practices: https://www.w3.org/TR/wai-aria-practices/#TreeView

Worth noting how keyboard interaction works just with the arrow keys (the whole tree view has just one Tab stop).

From a visual perspective, I'd say the currently selected folder/file needs a way to indicate it's the current item that doesn't rely on color alone.

#3 @melchoyce
3 months ago

From a visual perspective, I'd say the currently selected folder/file needs a way to indicate it's the current item that doesn't rely on color alone.

Related: #31604

#4 @westonruter
2 months ago

  • Priority changed from normal to high

Bumping priority to high for visibility and alignment with 4.9 goals, and given proximity to beta 1 deadline.

#5 @melchoyce
2 months ago

  • Keywords ui-feedback added

#6 @karmatosed
2 months ago

This I feel needs to be a little more obvious than just icons. What about a rough idea of:

https://cldup.com/aGeuA0ouqF.png

This ticket was mentioned in Slack in #design by karmatosed. View the logs.


2 months ago

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


2 months ago

#10 @jbpaul17
7 weeks ago

  • Keywords needs-patch added

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


7 weeks ago

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


7 weeks ago

#13 @westonruter
7 weeks ago

@melchoyce I think this should be closed as a duplicate of #24048, and your designs can be provided there.

#14 @melchoyce
7 weeks ago

  • Milestone 4.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24048.

Sure, I'll move that over now.

Note: See TracTickets for help on using tickets.