WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#42166 closed enhancement (duplicate)

Bundle fonts used by default themes

Reported by: stefannagy Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Themes Keywords:
Focuses: Cc:
PR Number:

Description

Please consider to not use the Google Fonts API in the default themes anymore. Website operators and visitors in most cases don't even know that they use Google services and pay with their data as soon as they install WP.

It seems to be OK that these themes use fonts that only support latin languages. In my view it should also be ligitimate if only browsers with WOFF2 and unicode-range support can make use of these webfonts.

If WP decided to bundle only the relevant WOFF2 subsets (with hints) the additional data volume should be acceptable and performance shouldn't suffer much. For a free software project it could be much worse to lose trust – WP already earned a 'dispraising mention' in this year's german Big Brother Awards…

Change History (2)

#1 @dd32
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Ho @stefannagy and welcome to Trac,

Discussion relating to bundling fonts was handled in #26072 and ultimately was chosen not to do so, for many technical reasons utilising an optimised fonts CDN is more efficient and provided a better user experience.

We also used to use OpenSans in WordPress admin itself, however we dropped that in #36753 in favour of system fonts.

While I can't promise you that future default themes won't use Google Fonts if it provides the best user experience, know that it's always taken into consideration during the theme design process, and if anything, the fact we no longer need to use OpenSans in the admin should be a good sign for the future.

#2 @stefannagy
2 years ago

Hi @dd32,

We also used to use OpenSans in WordPress admin itself, however we dropped that in #36753 in favour of system fonts.

While I can't promise you that future default themes won't use Google Fonts if it provides the best user experience, know that it's always taken into consideration during the theme design process, and if anything, the fact we no longer need to use OpenSans in the admin should be a good sign for the future.

I'm really glad you dropped OpenSans in the admin panel in favour of system fonts. But in my view theme fonts are a different problem – that's why I don't think that this ticket is a duplicate of #26072. When we talk about fonts in themes it's not a real option to drop them in favour of system fonts.

The WP default themes seem to be designed for users with latin languages; in case of greek, cyrillic… charsets system fonts are used instead of the careful chosen ones. I'm quite sure that the reason for this is not because fonts are not so important for designers after all but because default themes are something like 'showcase themes' and it's just impossible to create a beautiful design that works for / with all different writing systems / charsets.

In case of OpenSans you were talking about a font that supports many charsets (cyrillic, cyrillic-ext, greek, greek-ext, latin, latin-ext, viatnamese) while in case of Libre Franklin and most other fonts used in default themes we're talking about fonts that support only two charsets (latin and latin-ext). Apart from that as I understand it today most browsers support WOFF2 and unicode-range subsetting.

So I opened this ticket because 1. default themes are different use cases – with different alternative options (dropping carefully chosen fonts in favour of system fonts is not one of them) and 2. in the last four years the basis for decision-making changed.

Note: See TracTickets for help on using tickets.