WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 3 months ago

#44087 closed defect (bug) (duplicate)

Duplicate case in Entities.php

Reported by: akshayar Owned by:
Milestone: Priority: lowest
Severity: normal Version:
Component: External Libraries Keywords:
Focuses: Cc:
PR Number:

Description

There is duplicate 'case' present for "\x0B" in 'entity()' function of 'SimplePie_Decode_HTML_Entities' class present at 'wp-includes/SimplePie/Decode/HTML/Entities.php'

Code Reference : https://github.com/WordPress/wordpress-develop/blob/e72d50370273c2741329e1a102ec90b35cf1b492/src/wp-includes/SimplePie/Decode/HTML/Entities.php#L172

Attachments (1)

44087.patch (743 bytes) - added by akshayar 19 months ago.
Removed duplicate 'case - \x0B' line

Download all attachments as: .zip

Change History (3)

@akshayar
19 months ago

Removed duplicate 'case - \x0B' line

#1 @swissspidy
19 months ago

  • Component changed from General to External Libraries
  • Priority changed from normal to lowest

Note that SImplePie is an external library. We don't usually write patch those in WordPress, but instead update to a newer version of a dependency or provide a patch to them, if it doesn't exist.

Looks like this has been fixed in SimplePie three years ago: https://github.com/simplepie/simplepie/commit/eaf1c189ed848237e2a51e9b69d8a05348ca8bfe#diff-9e7f3dbb4c2d2943e7a8e851260afac6

#2 @desrosj
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for this ticket @akshayar! As @swissspidy noted above, this was fixed upstream. Because the library needs to be updated for the fix to be included, I'm going to markt his as a duplicate of #36669, which aims to update the library in 5.4.

Note: See TracTickets for help on using tickets.