WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#45368 closed defect (bug) (worksforme)

Update fail when adding 2 dots (..) to a source code block.

Reported by: vietanhdev Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.8
Component: Editor Keywords:
Focuses: Cc:
PR Number:

Description

After adding a source code block containing 2 dots (..) like this source code, I cannot save the post anymore.
I have to replace .. as something like 2dotsxyz and replace it back to .. using database tool.

cmake -D CMAKE_BUILD_TYPE=RELEASE \
	-D CMAKE_INSTALL_PREFIX=/usr/local \
	-D INSTALL_PYTHON_EXAMPLES=ON \
	-D INSTALL_C_EXAMPLES=OFF \
	-D OPENCV_EXTRA_MODULES_PATH=~/opencv_contrib/modules \
	-D PYTHON_EXECUTABLE=~/.virtualenvs/cv/bin/python \
        -D WITH_TBB=ON \
        -D WITH_V4L=ON \
        -D WITH_QT=ON \
	-D BUILD_EXAMPLES=ON \
        ..

Change History (6)

#1 follow-ups: @swissspidy
12 months ago

  • Keywords reporter-feedback added
  • Severity changed from critical to normal

Hi and welcome to WordPress Trac!

Which version of WordPress and Gutenberg are you using?

I tested this using WordPress 5.0 Beta 5 and was able to insert a code block with the given code just fine. So I cannot reproduce this issue.

Please try to disable all other plugins to see if this error still occurs. Also check your browser's developer console to see if there are any errors.

#2 in reply to: ↑ 1 @vietanhdev
12 months ago

Replying to swissspidy:

Hi and welcome to WordPress Trac!

Which version of WordPress and Gutenberg are you using?

I tested this using WordPress 5.0 Beta 5 and was able to insert a code block with the given code just fine. So I cannot reproduce this issue.

Please try to disable all other plugins to see if this error still occurs. Also check your browser's developer console to see if there are any errors.

Hello,
I'm using Wordpress 4.9.8 with Gutternberg 4.4.0. I've tried to disable all plugins but it could not help.

I've tried to paste only the source code to the new post and it worked. But when I tried to paste the html code of all old post, It failed.
Please try with this code: https://codeshare.io/GLvNQK.

On the browser console, I saw some errors (Screenshot).
https://www.learncv.com/wp-content/uploads/2018/11/Screenshot-from-2018-11-18-15-56-05.png
Tell me if you need other information.

Last edited 12 months ago by vietanhdev (previous) (diff)

#3 in reply to: ↑ 1 @vietanhdev
12 months ago

Last edited 12 months ago by vietanhdev (previous) (diff)

#4 @vietanhdev
12 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Resolved after updating to the lastest wordpress version.

#5 @SergeyBiryukov
12 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

#6 @SergeyBiryukov
12 months ago

FWIW, it sounds like .. triggers some overzealous security rule on your server.

Related: #25564, #25736, #32571, #33160, #44861.

Note: See TracTickets for help on using tickets.