WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#46138 closed enhancement (duplicate)

REST API: Include shortcode enqueued scripts in oEmbed proxy response

Reported by: aduth Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Embeds Keywords:
Focuses: rest-api Cc:

Description

If an embed generated by the oEmbed proxy endpoint is handled by a shortcode, it might enqueue scripts necessary for its preview. In GB9734, the oEmbed proxy endpoint was enhanced to include enqueued scripts as part of the embed response. Similar functionality should be brought to core, or decided against (both in closing this ticket and removing the functionality from Gutenberg).

Related:

cc @notnownikki

Change History (1)

#1 @swissspidy
3 years ago

  • Component changed from REST API to Embeds
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #45447.

Note: See TracTickets for help on using tickets.