WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#48129 closed task (blessed) (fixed)

There isn't different of color between Select disabled and enabled

Reported by: adhitya03 Owned by: kjellr
Milestone: 5.3 Priority: normal
Severity: normal Version: 5.3
Component: Administration Keywords: has-patch has-screenshots 5-3-admin-css-changes
Focuses: ui, accessibility Cc:

Description

In Reading Settings, When we want to choose what page as home page, between "Your latest posts" or "A static page (select below)", there is no different of color on that drop-down.

Attachments (6)

Screenshot_22.png (172.4 KB) - added by adhitya03 5 months ago.
Before Patch
48129.diff (361 bytes) - added by adhitya03 5 months ago.
Patch
Screenshot_23.png (172.9 KB) - added by adhitya03 5 months ago.
After patch
48129.2.diff (924 bytes) - added by kjellr 5 months ago.
48129.3.diff (886 bytes) - added by MarcosAlexandre 5 months ago.
48129.4.diff (852 bytes) - added by adhitya03 5 months ago.

Download all attachments as: .zip

Change History (15)

@adhitya03
5 months ago

Before Patch

@adhitya03
5 months ago

Patch

@adhitya03
5 months ago

After patch

#1 @afercia
5 months ago

  • Component changed from General to Administration
  • Focuses administration removed
  • Milestone changed from Awaiting Review to 5.3
  • Owner set to kjellr
  • Status changed from new to assigned

Thanks @adhitya03 good catch! Assigning @kjellr for now, see [46243] / #47477

@kjellr
5 months ago

#2 @kjellr
5 months ago

Thanks for the report and for the patch, @adhitya03.

The styles for the select dropdown are based on our button styles. Since the buttons don't use opacity for the disabled state, I'd prefer we don't use it here either. I'm attaching 48129.2.diff, which uses the same disabled styles we use for buttons in buttons.css (plus the addition of a lighter gray variant of the arrow SVG).

Screenshot:

https://cldup.com/mhrztH2qq0-3000x3000.png

This ticket was mentioned in Slack in #core by garrett-eclipse. View the logs.


5 months ago

#4 @MarcosAlexandre
5 months ago

Thanks for the comments @kjellr
Removed !important, added element ID

#5 @adhitya03
5 months ago

Hi @MarcosAlexandre thanks for the patch.

I think the patch should effect to all disabled state of select, instead of only for one part. I'd prefer @kjellr 's patch.

@adhitya03
5 months ago

#6 @adhitya03
5 months ago

Reproduce from @kjellr 's patch, delete !important property. All style work fine without that.

#7 @kjellr
5 months ago

Sounds good to me. We do use !important styles for these in buttons.css, but I'm much happier not using them if we can help it.

48129.4.diff should be good to go. Thanks for the help, everyone!

#8 @afercia
5 months ago

  • Keywords 5-3-admin-css-changes added
  • Type changed from defect (bug) to task (blessed)

#9 @afercia
5 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 46339:

Accessibility: Improve and modernize user interface controls. Style the select elements disabled state.

Props adhitya03, MarcosAlexandre, kjellr.
See #47477.
Fixes #48129.

Note: See TracTickets for help on using tickets.