WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 months ago

Last modified 2 months ago

#51464 closed defect (bug) (duplicate)

Theme details modal z-index too high

Reported by: MarkS99 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords: needs-testing has-screenshots
Focuses: ui, accessibility, administration Cc:

Description

When theme details modal is open, the sidebar menu sub-menu items are not viewable, as the modal z-index is too high.
https://www.dropbox.com/home/WP-Bugs?preview=Screenshot+2020-10-07+at+10.21.28.jpg

By setting the following, the side menus are still useable.

.theme-overlay .theme-backdrop {
	position: absolute;
	left: -20px;
	right: 0;
	top: 0;
	bottom: 0;
	background: #f1f1f1;
	background: rgba(238, 238, 238, 0.9);
	**z-index: 9;**
}
.theme-overlay .theme-wrap {
	clear: both;
	position: fixed;
	top: 9%;
	left: 190px;
	right: 30px;
	bottom: 3%;
	background: #fff;
	box-shadow: 0 1px 20px 5px rgba(0, 0, 0, 0.1);
	**z-index: 10;** 
	box-sizing: border-box;
	-webkit-overflow-scrolling: touch;
}

With Z-index changed:
https://www.dropbox.com/home/WP-Bugs?preview=Screenshot+2020-10-07+at+10.29.41.jpg

Have not tested fully if this causes other issues. But think it needs looked at.

Change History (5)

This ticket was mentioned in Slack in #core-css by ryelle. View the logs.


3 months ago

#3 @preciousomonze
3 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #42595.

A similar ticket is already helping with this.
Thanks for the submission 🚀

#4 @sabernhardt
3 months ago

I found out this was reported even earlier on ticket #41155.

If you would like to join the discussion there, please do so.

#5 @desrosj
2 months ago

  • Component changed from General to Themes
  • Focuses administration added; css removed
  • Milestone Awaiting Review deleted
  • Version 5.5.1 deleted

Duplicate of #41155.

Note: See TracTickets for help on using tickets.