WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#52340 closed defect (bug) (duplicate)

When doing Add Media - Insert from URL caption textarea fills with HTML markup due to improper HTML

Reported by: mwheelermindbox Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: Media Keywords:
Focuses: template, coding-standards Cc:

Description

When creating/editing a post and choosing "Add Media" and then "Insert from URL" in the sidebar of the modal, and entering the URL of the image the caption field is filled with the markup for the alignment and link button bars.

Line 1023 of wp-includes/media-template.php is:

<textarea id="embed-image-settings-caption" data-setting="caption" />

but textarea is not allowed to be a self-closing tag, so in Chrome (and possibly other browsers) this textarea gets filled with the markup to control image layout.

This is all fixed if line 1023 is changed to the proper markup of:

<textarea id="embed-image-settings-caption" data-setting="caption"></textarea>

Change History (1)

#1 @sabernhardt
8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #52065.

@mwheelermindbox Thanks for the report!

The textarea is fixed now, as of changeset:49804. That will be included soon in the next minor version, 5.6.1.

Note: See TracTickets for help on using tickets.