WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

#52872 closed enhancement (wontfix)

Title added on the "Noteworthy Contributors" section on the Credits page

Reported by: Laxman Prajapati Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Help/About Keywords: has-patch needs-refresh
Focuses: accessibility Cc:

Description

I think we should add the contributor's name as a title so it will be displayed on hover.

Attachments (2)

52872.patch (1022 bytes) - added by Laxman Prajapati 6 months ago.
Created patch.
title-on-hover-added.png (77.1 KB) - added by Laxman Prajapati 6 months ago.
Will be displayed like this.

Download all attachments as: .zip

Change History (8)

@Laxman Prajapati
6 months ago

Created patch.

#1 @Laxman Prajapati
6 months ago

  • Keywords has-patch added

@Laxman Prajapati
6 months ago

Will be displayed like this.

#2 @Laxman Prajapati
6 months ago

  • Type changed from defect (bug) to enhancement

#3 @SergeyBiryukov
6 months ago

  • Component changed from Customize to Help/About
  • Focuses coding-standards removed

#4 @SergeyBiryukov
6 months ago

Hi there, thanks for the ticket and the patch!

As previously noted in comment:25:ticket:42888, WordPress has been progressively removing title attributes from its codebase in the last years. It's important to not introduce new title attributes, as they serve no useful purpose, are usually redundant, available only to mouse users, and thus they are not accessible. See #24766 for more context.

#5 @mukesh27
6 months ago

  • Keywords needs-refresh added

Hi there!

If we consider title attribute then we have to use esc_html( $person_data[0] ) instead of esc_attr( $person_data[0] ) because we already use it in credits.php#L156

#6 @peterwilsoncc
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
  • Version 5.7 deleted

As mentioned earlier, WordPress has been removing title attributes due to accessibility concerns.

In this case, I think it is redundant as the name of the person is displayed inline. Adding titles risks screen reader users (depending the software used) hearing "Matt Mullenweg Matt Mullenweg" and so on for each of the contributors.

As WP has been removing title attributes by design, I'm going to close this ticket off.

Note: See TracTickets for help on using tickets.