WordPress.org

Make WordPress Core

Opened 6 months ago

Last modified 5 months ago

#53047 reopened defect (bug)

My "Posts" page (when a static front is selected) uses the old editor

Reported by: DavidSortOf Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Editor Keywords: needs-testing needs-testing-info
Focuses: Cc:

Description

I'm using WP 5.7.1.

Very strange, minor bug:

Every page, except my Posts page, uses the Gutenberg editor. I'm told on the support forums that this is not normal.

The Posts page, when I enter Edit, calls up what looks like the previous-generation editor.

This persists when all plug-ins are deactivated. It even persists on another of my sites, which uses a completely different WP installation.

Unfortunately, I don't know how this can be reproduced, since I can't make it NOT happen.

Let me know what other info I can provide!

Attachments (4)

53047.front-page.png (60.7 KB) - added by SergeyBiryukov 6 months ago.
53047.posts-page.png (68.0 KB) - added by SergeyBiryukov 6 months ago.
Screenshot_2021-04-17 Edit Page — WordPress.png (53.1 KB) - added by knutsp 6 months ago.
Posts Page
Screenshot_2021-04-17 Edit Page—WordPress-no-content.png (53.2 KB) - added by knutsp 6 months ago.
No content area

Download all attachments as: .zip

Change History (15)

#1 @knutsp
6 months ago

  • Keywords close added
  • Version 5.7.1 deleted

Hello @DavidSortOf, welcome to Trac and thanks for the ticket!

The posts page is just a placeholder for generated content, and has no editable text content at all. Not loading the the block editor seems to be the intended behaviour in this special case.

#2 @DavidSortOf
6 months ago

Thank you @knutsp! I suspected that that may be the case. I will officially not worry about this.

  • David

#3 @knutsp
6 months ago

  • Keywords close removed
  • Resolution set to worksforme
  • Status changed from new to closed

#4 follow-up: @SergeyBiryukov
6 months ago

Hi there, welcome to WordPress Trac and thanks for the report!

Every page, except my Posts page, uses the Gutenberg editor. I'm told on the support forums that this is not normal.

The Posts page, when I enter Edit, calls up what looks like the previous-generation editor.

Just noting that I could not reproduce this on a clean install.

When selecting a static page as a front page and another one as a page for posts, both pages display a Classic block in the block editor, see 53047.front-page.png and 53047.posts-page.png.

#5 in reply to: ↑ 4 @knutsp
6 months ago

Replying to SergeyBiryukov:

When selecting a static page as a front page and another one as a page for posts, both pages display a Classic block in the block editor, see 53047.front-page.png and 53047.posts-page.png.

Not here.

#6 follow-up: @knutsp
6 months ago

Some times there is is an editable text area, sometimes not. This should probably be investigated.

#7 in reply to: ↑ 6 @SergeyBiryukov
6 months ago

Replying to knutsp:

Some times there is is an editable text area, sometimes not. This should probably be investigated.

The editable area is displayed if the content of the page is not empty, see [31550] / #17470.

It looks like the classic editor / block editor loading could use more investigation, though.

#8 @knutsp
6 months ago

Tried to remove any content using text view, seems not possible.

Also related: #47198 #45537

#9 @desrosj
5 months ago

  • Milestone Awaiting Review deleted

It looks like the classic editor / block editor loading could use more investigation, though.

Should this ticket be reopened @SergeyBiryukov? Or should this investigation happen elsewhere?

#10 @SergeyBiryukov
5 months ago

  • Keywords needs-testing needs-testing-info added
  • Milestone set to Awaiting Review
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Let's reopen for now :)

#11 @grantmkin
5 months ago

Some times there is is an editable text area, sometimes not. This should probably be investigated.

I believe there was an unintended change introduced in [50693] that causes this.

More details: https://core.trac.wordpress.org/ticket/52995#comment:5

Last edited 5 months ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.