WordPress.org

Make WordPress Core

Opened 8 weeks ago

Closed 8 weeks ago

Last modified 3 weeks ago

#53798 closed defect (bug) (invalid)

Page template is missing from page attributes

Reported by: ncweb Owned by:
Milestone: Priority: normal
Severity: major Version: 5.8
Component: Administration Keywords:
Focuses: Cc:

Description

Hi,

I've noticed page template is missing from page attributes since 5.8.

I've made a request for support here : https://wordpress.org/support/topic/page-templates-missing-from-page-attributes-after-5-8/

Searching further the issue, I've created a new blank WordPress install on my local environment with a minimum theme, a page template and no plugin.

On previous WordPress core version, my minimal setup showed the select for my page template under page attributes, in the admin editor (Gutenberg).

When updating to 5.8, the select disapeared.

It happened to all the site I manage that are currently online. Except those who use the Classic Editor plugin.

The snippet that just follows outputs all the templates.

 wp_get_theme()->get_page_templates( $post, $post_type )

Pages that were assigned a template before the update still show the right template, so it seems it's about the select dropdown only.

If I can help you in any way please let me know,
If it's my mistake and not a bug, I'm sorry. This ticket is for contribution only.

Best regards,

Change History (3)

#1 @ncweb
8 weeks ago

  • Resolution set to invalid
  • Status changed from new to closed

#2 @ncweb
8 weeks ago

Ticket is closed.

There's a new location in the Gutenberg sidebar for templates...

#3 @desrosj
3 weeks ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.