Make WordPress Core

#57204 closed defect (bug) (fixed)

Twenty Sixteen: Quote block text color does not affect citation text

Reported by: nidhidhandhukiya's profile nidhidhandhukiya Owned by: audrasjb's profile audrasjb
Milestone: 6.3 Priority: normal
Severity: normal Version: 6.1.1
Component: Bundled Theme Keywords: has-patch has-screenshots has-testing-info commit
Focuses: css Cc:

Description

Steps to reproduce the issue.

  1. Activate Twenty sixteen theme.
  2. Choose Quote block.
  3. Give text color to the text.

You can able to see text color is reflected on the heading only.
And, border color is different in frontend and user side.
I have attached video for better understanding.
URL :- https://share.cleanshot.com/Trob0O4LnouOhVXaP2k2

Attachments (4)

57204.patch (1.0 KB) - added by nidhidhandhukiya 17 months ago.
57204.1.patch (927 bytes) - added by sabernhardt 10 months ago.
Capture d’écran 2023-06-28 à 01.03.41.png (204.2 KB) - added by audrasjb 10 months ago.
Patch doesn't fix the issue anymore
Capture d’écran 2023-06-28 à 09.50.36.png (303.3 KB) - added by audrasjb 10 months ago.

Download all attachments as: .zip

Change History (14)

#1 @sabernhardt
10 months ago

The border issue was already reported on #56565.

Adjusting the citation text color for Quote blocks with the .has-text-color class would be a follow-up to the Pullquote changes in [54381].

#2 @sabernhardt
10 months ago

  • Keywords has-patch added
  • Summary changed from Twenty Sixteen - Quote block text color is having issue. to Twenty Sixteen: Quote block text color does not affect citation text

#3 @sabernhardt
10 months ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 6.3

#4 @shailu25
10 months ago

  • Keywords has-screenshots added

Test Report For https://core.trac.wordpress.org/attachment/ticket/57204/57204.1.patch

Backend:
========
Before Patch Backend : https://prnt.sc/E7HjokNaZrGJ
After Patch Backend : https://prnt.sc/arwyxUPJn3Cf

Frontend:
=========
Before Patch Frontend: https://prnt.sc/Fz-LjCMkOdz6
After Patch Frontend : https://prnt.sc/ZMjgvxnhEY8H

https://core.trac.wordpress.org/attachment/ticket/57204/57204.1.patch is working fine as expected.

Result After Patch:

  • text color is reflecting Heading & citation text in frontend side & editor.
Last edited 10 months ago by shailu25 (previous) (diff)

#5 @anilvaza
10 months ago

  • Keywords has-testing-info added

Test Report for https://core.trac.wordpress.org/attachment/ticket/57204/57204.1.patch

Environment:
WordPress - 6.3-alpha
Theme - Twenty Sixteen
Os: Windows
Browser: Chrome

Backend:
=======
Before Patch Backend: https://prnt.sc/adwFoU258d0y

After Patch Backend : https://prnt.sc/JZ0dirBpDpt9

Frontend:
=========
Before Patch Frontend: https://prnt.sc/uFSZ3grjk6ZX

After Patch Frontend : https://prnt.sc/-wqqzBe42RUd

https://core.trac.wordpress.org/attachment/ticket/57087/57087.3.diff is working as expected.

@audrasjb
10 months ago

Patch doesn't fix the issue anymore

#6 @audrasjb
10 months ago

Hey @sabernhardt thanks for the patch!
It looks like it doesn't fix the issue anymore, though… maybe a change on Gutenberg side?

#7 @sabernhardt
10 months ago

I think you might have set the text color on the nested Paragraph block instead of the Quote block. It's a bit confusing. If you change the full Quote block color, the border color matches the text when viewing the front end (though not in the editor—see #56565).

#8 @audrasjb
10 months ago

  • Keywords needs-testing removed

Oh, thanks @sabernhardt!
The patch works fine, you're right.

#9 @audrasjb
10 months ago

  • Keywords commit added
  • Owner set to audrasjb
  • Status changed from new to accepted

#10 @audrasjb
10 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 56087:

Twenty Sixteen: Twenty Ten: Reflect Quote block text color on the entire block.

This changeset fixes an issue where the selected text color for the Quote block was not reflected on all the elements of the block.

Props nidhidhandhukiya, sabernhardt, audrasjb, shailu25, anilvaza.
Fixes #57204.

Note: See TracTickets for help on using tickets.