Make WordPress Core

Opened 9 months ago

Closed 2 months ago

#58783 closed defect (bug) (fixed)

Alternative text entered whilst uploading an image is lost when the image finished uploading

Reported by: codepo8's profile codepo8 Owned by: joedolson's profile joedolson
Milestone: 6.5 Priority: normal
Severity: normal Version:
Component: Media Keywords: has-patch has-testing-info commit
Focuses: ui, accessibility Cc:

Description

When uploading images in WordPress' Media editor, I keep typing alternative text while the image uploads just to lose it immediately when the image has uploaded. This is frustrating and should work differently.

Attachments (2)

WP-ALT-TEXT.gif (188.9 KB) - added by codepo8 9 months ago.
Screencast of the failed entry of alternative text
58783.diff (487 bytes) - added by joedolson 3 months ago.
Disallow local edits while uploading

Download all attachments as: .zip

Change History (29)

@codepo8
9 months ago

Screencast of the failed entry of alternative text

#1 @joedolson
9 months ago

  • Owner set to joedolson
  • Status changed from new to accepted

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


9 months ago

#3 @joedolson
9 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 6.4
  • Severity changed from major to normal
  • Type changed from enhancement to defect (bug)

This ticket was mentioned in Slack in #core-media by joedolson. View the logs.


9 months ago

#5 @joedolson
9 months ago

Following discussion of this issue, the only viable solution is that the input fields should be disabled or removed until the image has completed uploading. The bug is that we should not provide fields to add meta data for a database record that does not yet exist.

#6 @joedolson
9 months ago

  • Keywords reporter-feedback added

Hi, @codepo8! On testing, we're finding that we can't reproduce this in our current environments; we've tested on Android/Chrome, Windows 10/Chrome, Windows 10/Firefox, an MacOS/Chrome, and on all of those environments the input fields are disabled while uploading.

What's your environment for this?

This ticket was mentioned in Slack in #accessibility by amberhinds. View the logs.


8 months ago

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


7 months ago

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


7 months ago

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


6 months ago

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


6 months ago

#12 @oglekler
6 months ago

I was unable to fill in anything while the file was downloading, I have all fields stubbornly disabled. We need steps to reproduce the issue. But I can agree it would be great to be able to fill in the whole additional information while the file is still in progress and not waiting, so it might be worth considering.

But I noticed another thing, that can be addressed in the another ticket: when you are uploading something and want to switch view, the page reloads without any warning that that progress of upload progress will be lost. I would suggest that while the file is in progress, it would be worth adding an event listener to all links on the page and asking the user to confirm the page reload.

#13 @nicolefurlan
6 months ago

@codepo8 could you review #comment:6 and provide information on your environment?

#14 @codepo8
6 months ago

My environment is Microsoft Edge on Mac.

#15 @nicolefurlan
6 months ago

I just tested this on Microsoft Edge version 117.0.2045.55 on MacOS Ventura 13.4 and the fields all have the readonly attribute in the attachment details window while an image is uploading.

The video is too big to upload here so here's a link: https://imgur.com/a/2q6oQQ4

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


6 months ago

#17 @oglekler
6 months ago

  • Milestone changed from 6.4 to 6.5

Because we have 3 days before RC1, I am moving this ticket to the next milestone for further investigation.

#18 @joedolson
3 months ago

  • Keywords reporter-feedback removed

So, this problem occurs because the readonly attribute is not consistently applied. In the classic editor, if you use the 'Add Media' button above the content area, readonly is not applied during uploading. It is applied in the version of the modal that is used for featured images and in media modals in the block editor.

So this appears to be specific to the version of the add media modal triggered above the classic editor content area. That same view may be called elsewhere or by plugins, so even though the classic editor is a non-default usage, this should be fixed.

@joedolson
3 months ago

Disallow local edits while uploading

#19 @joedolson
3 months ago

  • Keywords has-patch needs-testing has-testing-info added; needs-patch removed

The attached patch disables local editing while an image is uploading. In my testing, this resolves the issue.

To test:

  • Use the classic editor's "Add Media" link to upload items.
  • Upload a large image or multiple images. (Small images will upload too quickly, and you won't be able to inspect what's happening.)
  • Verify that before the patch, the input fields for uploading images are editable; and after the patch, those same fields are readonly for images that are actively uploading, but editable for images that have completed uploading.

This ticket was mentioned in Slack in #core-media by joedolson. View the logs.


3 months ago

This ticket was mentioned in Slack in #core-media by joedolson. View the logs.


3 months ago

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


2 months ago

#23 @antpb
2 months ago

Confirmed patch looks good and works in my testing. 👍

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


2 months ago

#25 @joedolson
2 months ago

  • Keywords commit added; needs-testing removed

#26 @syamraj24
2 months ago

Environment

  • WordPress: 6.4.4-alpha-57488
  • PHP: 8.0.1
  • Server: Apache/2.4.33 (Win64) OpenSSL/1.0.2u mod_fcgid/2.3.9 PHP/8.0.1
  • Database: mysqli (Server: 5.7.24 / Client: mysqlnd 8.0.1)
  • Browser: Chrome 120.0.0.0 (Windows 10/11)
  • Theme: Twenty Twenty-Three 1.3
  • MU-Plugins: None activated

I've tested the patch and it works as expected.

#27 @joedolson
2 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 57515:

Media: Prevent local edits during media upload.

Prevent options.allowLocalEdits from toggling to true during the upload cycle. Otherwise, media meta fields can be edited, but the data will be lost as soon as the upload process is completed.

Props codepo8, oglekler, nicolefurlan, antpb, syamraj24, joedolson.
Fixes #58783, #23374.

Note: See TracTickets for help on using tickets.