Make WordPress Core

Opened 10 months ago

Closed 9 months ago

Last modified 9 months ago

#59144 closed defect (bug) (invalid)

6.3 Auto update completely broke website

Reported by: seedyrom's profile seedyrom Owned by:
Milestone: Priority: normal
Severity: critical Version:
Component: General Keywords:
Focuses: Cc:

Description

Upon my site getting updated automatically, it no longer loads on the front end or admin panel. I get the following error:

( ! ) Warning: require(/Users/<USER>/Local Sites/<SITE>/app/public/wp-includes/class-wp-duotone.php): Failed to open stream: No such file or directory in /Users/<USER>/Local Sites/<SITE>/app/public/wp-settings.php on line 178
Call Stack
#    Time    Memory    Function    Location
1    0.0021    367504    {main}( )    .../index.php:0
2    0.0021    367816    require( '/Users/<USER>/Local Sites/<SITE>/app/public/wp-blog-header.php )    .../index.php:17
3    0.0021    368456    require_once( '/Users/<USER>/Local Sites/<SITE>/app/public/wp-load.php )    .../wp-blog-header.php:13
4    0.0022    369056    require_once( '/Users/<USER>/Local Sites/<SITE>/app/public/wp-config.php )    .../wp-load.php:50
5    0.0022    377984    require_once( '/Users/<USER>/Local Sites/<SITE>/app/public/wp-settings.php )    .../wp-config.php:102

I saw another person with a similar issue on the forums https://wordpress.org/support/topic/automatic-update-to-6-3-completely-broke-everything-2/#post-16966735, seems like the upgrade never completed? When I try to manually upgrade at /wp-admin/upgrade.php I can an internal error that isn't showing up in the logs.

Change History (4)

#1 @SergeyBiryukov
10 months ago

Hi there, welcome to WordPress Trac! Thanks for the report.

I'm sorry to hear you are having an issue with your website. It looks like the error is caused by an incomplete upgrade, specifically the wp-includes/class-wp-duotone.php file is missing.

I would suggest downloading the latest version of WordPress and replacing the wp-includes directory with a fresh copy, that should fix the issue.

#2 @seedyrom
10 months ago

That worked! Thank you!!!

But to get to the root of the issue, why would an upgrade not finish? I saw somebody else with an identical error, if something like this just happened. Should I trust auto updates in the future?

#3 @drumbrent
9 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Hi @seedyrom, jumping in here. Updates can fail for numerous reasons. I can't possibly diagnose without seeing more context from your environment, but re-running the update usually solves the issue. Auto-updates are usually fine to trust, but I always recommend running the update either in a staging environment and/or making a backup of your filesystem and database. Since your issue is solved, I'm going to close this ticket out.

#4 @SergeyBiryukov
9 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.