WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22419 closed defect (bug) (duplicate)

Fatal error when showing images

Reported by: knutsp Owned by:
Milestone: Priority: normal
Severity: critical Version: 3.5
Component: Media Keywords: needs-patch
Focuses: Cc:

Description (last modified by SergeyBiryukov)

PHP Fatal error:  Using $this when not in object context in /wp-includes/class-wp-image-editor-imagick.php on line 153

PHP: 5.3.17

Probably introduced in changeset [22421]

Change History (4)

comment:1 @knutsp2 years ago

  • Severity changed from blocker to critical

The error happened on a development site after upgrading to latest beta and switching to WooThemes Canvas. The setting used is not to use TimThumb as the image resizer, hence using WordPress native image resizing. I am currently testing other themes. Anyway, the error seems to be in current trunk, as static class methods should never refer to an object instance, right? I'm not an expert on this, though.

comment:2 @nacin2 years ago

In 22549:

Revert [22421]. see #6821. see #22308. see #22419.

comment:3 @nacin2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22308.

comment:4 @SergeyBiryukov2 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.