WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24652 closed enhancement (duplicate)

Add "do_action" to menu editor to make it more customisable

Reported by: karevn Owned by:
Milestone: Priority: normal
Severity: major Version: 3.6
Component: Menus Keywords: has-patch
Focuses: Cc:

Description

Currently, one can override menu walker to tweak menu items when editing them at the admin, but there is no way to, say, add menu options not related to a specific menu item. I added a couple of action calls above and below menu items list.

Attachments (1)

extend-menu-editor.diff (956 bytes) - added by karevn 2 years ago.

Download all attachments as: .zip

Change History (2)

@karevn2 years ago

comment:1 @SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18584.

Note: See TracTickets for help on using tickets.